sprockets Commercial modeled and animated by serg2 Modeling demo by Michael Brennan Short film by Svetlik Making and Using Drop-On Poses TinkeringGnome's Atomic Rings PRJ 2001 Star Gate effect in A:M with PRJ Comparison of AO and Radiosity Renders
sprockets
Recent Posts | Unread Content
Jump to content
Hash, Inc. - Animation:Master

How to import Images into Mac?


Recommended Posts

Hey, I've downloaded and installed my trial version and getting back into AM is as easy as falling off a bike! However, on the Mac side how do you import images? I remember there was some workaround, which I haven't been able to figure out. But the usual "Import" window opens all grayed out.

Link to comment
Share on other sites

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Hash Fellow

Hi, Gerardo.



I've moved your post to a thread of its own so you are more likely to get the attention of a forum member who has an answer to your question.

I don't have a Mac, but if right-clicking on the Images folder doesn't work, can you drag an image from a directory folder directly into into A:M?

 

 

(OK, I just saw that that is good 'ol Gerry. Why are you under a new name??)

Link to comment
Share on other sites

Yeh, I forgot my password and when I applied for a new one it assigned this name, I don't know how that happened! Anyway, I was having trouble importing a jpeg so tried a tga and it worked fine.

Link to comment
Share on other sites

Gerry

I had a similar problem when I started using the Mac, it would appear to freeze when trying to import or open something. Apparently it wasa known bug but no one knew how to fix it. The workaround was to hide the program momentarily, by pressing cmd + H , then clicking on the icon on the desktop to go back to the program and the option is then available.

 

I've never like the one button mouse used by Macs so I always use a PC version. It seems to work just fine and it makes right mouse button op's easier than having to press the keyboard button at the same time. For me at least.

regards

simon

Link to comment
Share on other sites

Working with images on a mac either Rotoscope or Decals can be and will be a pain

and it will not matter which type png, jpg, tga ect...

 

you are going to run into problems especialy when you start to use more then one

 

There is a cure (disclaimer at least for me)

use the quick render button and scroll over the image that is giving you the problem

you might have to do this several times but it will bring all your decals and projections back to normal.

 

there is an however

when you go to another window and comeback you might have to do the quick scroll trick again

this is the only thing that works on my end and I've tried them all

 

If I were to make a guess as to why this is happening on the mac end

it has to do with the video card

 

Final thoughts it would be so so nice that the powers to be would get around to fixing this and or at least tell us

mac people what they are using on their

 

j

 

mac pro, quad core, nvidia Geoforce

Link to comment
Share on other sites

sorry there is no audio
but here is what it looks like on a mac
import jpg tag and png files using the Q key quick render trick
and this is just for rotos fixes same thing would apply to decals

note this test was using V13 (my last version was V18 ) however it does not matter what version of AM I use from 13 on it is the same
I had to stop using AM altogether because of this

and I would love to have it fixed so I could use the newest version

in the meantime I use 13 in frustration (:

AM_1.mp4

Link to comment
Share on other sites

Robert

I don't know the answer to that I'm afraid, as its the ones that come with the Imac and Mini as standard.

I'd wondered if it was an OSX incompatibility problem.

The installation on both machines is standard from point of purchase rather than updated ?

regards

simon

 

 

Pardon, just looked under "about this Mac'

 

this is te setup for the Imac

 

 

NVIDIA GeForce 9400:

Chipset Model: NVIDIA GeForce 9400
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0869
Revision ID: 0x00b1
ROM Revision: 3454
Displays:
iMac:
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected

Link to comment
Share on other sites

Hi guys

NVIDIA Geoforce GT 120 521

 

I can duel boot and have tried it on an early version of Mac os with the same results (same computer)

I do have a 2006 mac pro i could try and run some tests on there

 

 

Mac Pro (early 2009)

OS 10.10.5

2.66 GHz Quad Core Intel Xeon

18 gigs ram

 

I hope this subject stays active and more mac guys chime in so this could be resolved

Link to comment
Share on other sites

All my textures are either tga's (old ones) or png's. Both formats are not lossy and support 24 bit + alpha. There are issues with jpg's in general and usually the issue is with progressive scan rather than baseline standard. For kicks take a jpg and save out both types to see if thats the issue. Photoshop used to have problems with progressive scans, not sure if that was ever addressed.

Link to comment
Share on other sites

  • Hash Fellow

Here's what I get if I try to import a JPEG into the Mac version of A:M 18.0p SSE 4.2:

 

A project isn't necessary. It just doesn't import JPEGs anymore.

 

 

 

Is that new with v18p ? It worked in v18o? or some other v18?

Link to comment
Share on other sites

Don't know, Robert. Jpegs used to work, but when I started working on this last project I noticed that when I tried to access old materials and models that had jpegs associated with them, the jpegs didn't show up in the PWS.

Link to comment
Share on other sites

  • Admin

The first thing I'd do (troubleshooting-wise) would be to copy over an older image IO file from a previous installation (one that works in that older release).

It may be that file got corrupted somehow.

That very likely won't work but It's worth a shot.

 

On Windows those IO files are in the C:\Program Files\Hash Inc\v18.0\ImageIOS directory.

They have an IIO extension on windows with the file format as their name.

Not sure what they are named on the Mac platform.

Link to comment
Share on other sites

For kicks if you have Gimp or another photo editor other than Photoshop, save out a version as Baseline Standard and another as Progressive with 1 level.

Try to import either and see if any work.

 

Photoshop used to write corrupt progressive scan jpg files and I highly doubt Adobe put any effort in fixing it so don't use it to test. Photoshop will write a baseline standard file fine.

Link to comment
Share on other sites

I've been really swamped lately, but my solution was just to not use jpegs anymore. :-) It seems clear that if it couldn't load the jpegs that it used to be able to then it's not a matter of how new jpegs are being saved.

 

To be honest, I rarely use jpegs for A:M anyway. I mostly use png files since they have an alpha channel. That's probably why I hadn't noticed when it stopped working.

Link to comment
Share on other sites

Thinking back on it, I think the jpegs were messing with my netrender. I stopped using .jpg for A:M some time back. I remember reading somewhere that A:M prefers .tga. I didn't want to just spew bile about .jpgs not working with the program so I've been thinking about what it was that made me abandon using the jpegs. It very well may have been a 'gremlin' that I discovered while trying to render projects through Netrender. Netrender would crash on a project but the same project would render fine in A:M. I think I just troubleshot it until I realized that changing those .jpg decals out did the trick.

 

Adam

Link to comment
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...