Jump to content
Hash, Inc. Forums

Archived

This topic is now archived and is closed to further replies.

robcat2075

Using FakeAO as a post effect in an AM Composite

Recommended Posts

OpenEXR buffers make it possible to change lighting after you render and that includes FakeAO. Here's how to add FakeAO to a previously rendered image.

 

FakeAOinAMComposite.mov

 

You will see substantial banding in the images in the video. That is an artifact of the screencapture software, not A:M.

 

OpenEXR sequences can be quite large and slow for A:M to step through. OpenEXR does have compression options, which i don't demonstrate in this video, that may help negate some of that.

Share this post


Link to post
Share on other sites

Thanks RC .... good to know the process...

Share this post


Link to post
Share on other sites
Thanks RC .... good to know the process...

 

Easier than I thought it would be and much better than rendering it directly into the image.

Thanks for showing this Robert :).

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

Robert,

 

Awesome illustration..... Thank you for creating this and posting it.

 

It makes me more interested in working with A:M composite and EXR....

 

****I tried to run the shadow buffer, but it kept giving me a black screen. Works fine when I

only have the Alpha and depth buffers selected.

 

****If you want to control each of your lights in the scene(in AM Composite), which light setting should you choose? "Light objects" or "each light in it's own buffer?"

Share this post


Link to post
Share on other sites
****I tried to run the shadow buffer, but it kept giving me a black screen. Works fine when I

only have the Alpha and depth buffers selected.

 

I'm not sure on that.

 

 

 

****If you want to control each of your lights in the scene(in AM Composite), which light setting should you choose? "Light objects" or "each light in it's own buffer?"

 

If you want each light separate then choose "each light in it's own buffer?". "Light Objects" is a way to combine several lights into one buffer and I think the "light object" needs to be defined in the Chor somehow.

Share this post


Link to post
Share on other sites

I think there is something not entirely correct about how this works.

 

 

In v17 I don't get a Shadow Buffer option with EXR. I do with v16.

 

When you do a render with Shadow Buffer ON, you need to have a shadow catcher in the chor, typically the ground set to Shadows only.

 

The shadow information will show up in the alpha buffer of what appears to be a black image. Possibly incorrectly this gets named "Alpha buffer"

 

OpenEXR also creates a shadow buffer when it has light buffers, but this shadow buffer is only the shadow that is visible to the camera, not the complete shadow that a shadow catcher can render.

 

If you are doing something that uses shadow buffers you probably need to do three passes.

 

-the object casting the shadow

-the shadow

-the ground

 

then you would have three separate elements that can be properly composited in a compositing program.

Share this post


Link to post
Share on other sites
I think there is something not entirely correct about how this works.

 

 

In v17 I don't get a Shadow Buffer option with EXR. I do with v16.

 

When you do a render with Shadow Buffer ON, you need to have a shadow catcher in the chor, typically the ground set to Shadows only.

 

The shadow information will show up in the alpha buffer of what appears to be a black image. Possibly incorrectly this gets named "Alpha buffer"

 

OpenEXR also creates a shadow buffer when it has light buffers, but this shadow buffer is only the shadow that is visible to the camera, not the complete shadow that a shadow catcher can render.

 

If you are doing something that uses shadow buffers you probably need to do three passes.

 

-the object casting the shadow

-the shadow

-the ground

 

then you would have three separate elements that can be properly composited in a compositing program.

 

Shadow-Buffer is the one you get for TGA too... it only gives you the shadow out in the Alpha-channel and overwrite anything else... I think steffen did get rid of it because of that for EXR in v17.

It is not meant to be used with EXR anyway, since there you can work with each light separately, etc.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

I found that in V17 the only way to get a shadow only render is by using the PNG formatt.

 

I wish these could remain somewhat consistent. It's like doing the same research and development

over and over again when a new Version(s) comes out.

Share this post


Link to post
Share on other sites
I found that in V17 the only way to get a shadow only render is by using the PNG formatt.

 

I wish these could remain somewhat consistent. It's like doing the same research and development

over and over again when a new Version(s) comes out.

 

 

TGA will also work. The shadow info will be in the alpha buffer. That will reveal the portion of the otherwise black RGB image to make a shadow.

Share this post


Link to post
Share on other sites
I wish these could remain somewhat consistent. It's like doing the same research and development

over and over again when a new Version(s) comes out.

 

Well, things are somewhat consistent but keep in mind that the EXR format itself is changing. That alone will create some inconsistencies moving forward.

EXR is a forward leaning format and highly customizable (by programmers). For more consistency across the board you might want to use TGA. I hesitate to suggest PNG because it has issues... but in a pinch (mostly for web graphics) I'd consider that too.

 

The general rule: If you are having trouble with image formats... use Targa/TGA as your core image format.

Then convert to other formats from there.

 

TGA will also work. The shadow info will be in the alpha buffer. That will reveal the portion of the otherwise black RGB image to make a shadow.

 

What Robert said. What throws people here is that in looking at a preview we see Black on a plane of transparency (unfortunately also represented by black). So, the whole image is likely going to look black to you. You have to trust that it is there (relabel it if necessary) and then press on with it's use. If you open the image in A:M or Photoshop you'll see the shadow there and the transparency will allow everything else to be seen through. The Alpha buffer is a grayscale representation that tells a program what is opaque, what is transparent and what is partially see-through.

Share this post


Link to post
Share on other sites

Yeah, I always export to AE to see if the file actually has the shadow only result since the render appears all black.

 

But in After Effects, the TGA Shadow frame is still completely black. Only a PNG reveals the shadow in AE. Now keep in

mind that I may have made a mistake in the render process. But the same render setting for the TGA does not

produce a shadow only frame while the PNG render does.

Share this post


Link to post
Share on other sites
Yeah, I always export to AE to see if the file actually has the shadow only result since the render appears all black.

 

But in After Effects, the TGA Shadow frame is still completely black. Only a PNG reveals the shadow in AE. Now keep in

mind that I may have made a mistake in the render process. But the same render setting for the TGA does not

produce a shadow only frame while the PNG render does.

 

I just tried it and I did indeed get a shadow image in the alpha buffer. Possibly your After Effects was defaulting to "ignore" the alpha channel.

 

A simple test is to load the image into Photoshop and see if the alpha channel has anything in it.

Share this post


Link to post
Share on other sites
Yeah, I always export to AE to see if the file actually has the shadow only result since the render appears all black.

 

But in After Effects, the TGA Shadow frame is still completely black. Only a PNG reveals the shadow in AE. Now keep in

mind that I may have made a mistake in the render process. But the same render setting for the TGA does not

produce a shadow only frame while the PNG render does.

 

You will not directly see the shadow in the TGA... you have to interpret the Alpha in it. Try loading it into Photoshop and have a look into the channels.

In AE it should be possible to interpret the Alpha too... never had problems with that.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

×