sprockets Commercial modeled and animated by serg2 Modeling demo by Michael Brennan Short film by Svetlik Making and Using Drop-On Poses TinkeringGnome's Atomic Rings PRJ 2001 Star Gate effect in A:M with PRJ Comparison of AO and Radiosity Renders
sprockets
Recent Posts | Unread Content
Jump to content
Hash, Inc. - Animation:Master

A:M via Parallels on a Mac


largento

Recommended Posts

Hi everybody! Just wanted to post this on the off chance anyone wishing to use A:M on a Mac wonders if you can use Parallels to run the Windows version of A:M on a Mac.

I'm working on the third (and last!) of my Stalled Trek films and wanted to see if I could make use of some of my old files for extras on the boxed set I'm making, so I purchased a subscription to A:M and tried to use it in Parallels.

I'm using a Mac Studio with an M1 Max chip on Monterey. This is version 19.0P of A:M.

The chief issue is presumably graphic card related:

It's possible to see a model and tumble the view in wireframe, but shaded view doesn't work. (see screenshot.)

Screen Shot 2022-09-18 at 9.01.11 AM.png

 

Screen Shot 2022-09-18 at 9.02.16 AM.png

Quick render does work, so if you work entirely in wireframe mode, it is possible to use A:M.

It's not ideal, obviously.

IMPORTANT: Working with files is dependent on them being saved to the Local drive of Parallels. You can open files from your Mac, but saving to your Mac (including rendering), will crash A:M every time. Everything needs to be saved to the Local drive. 

This is something to consider when determining how much drive space to give to Windows.

I'm not doing much more than rendering some old shots and exporting models to OBJ, so I haven't done any kind of extensive testing. There may be other issues. Frankly, it's been so long since I've used A:M, I don't really remember how to do much. :-)

Hope this is helpful to anyone considering this as an option!

  • Like 2
Link to comment
Share on other sites

  • 5 months later...

I've got a Mac Studio M1 Ultra running Parallels with Windows 11 (ARM) and, following the prompts on the Hash Home site to install a trial version of A:M, I double click "get host id" and it just opens the same items in a new folder (see attached screenshot) instead of giving me a host ID to place on Hash's site.  Can you explain to me what I'm doing wrong.  I'd like to try using A:M 19 as you are doing.  Thanks, Chris

Screenshot 2023-02-24 at 11.11.27 AM.png

Link to comment
Share on other sites

  • Hash Fellow

I'll tag @largento so he sees your question.

In the mean time I found this tut on the web. Perhaps this gets you the number you need

Quote

 


How To Locate Host ID On Windows 10 Laptop and PCs?

Step 1: You need to open the Run box by pressing holding the Windows + R key simultaneously. 

Step 2: Once the Run box is open type in 'cmd' to open the command prompt.

Step 3: Now, in the command box type in ipconfig/all and press enter. This will open up the Windows IP configuration, Ethernet adapter, wireless LAN adapter, and other details.

Step 4: The 12-digit number mentioned in front of [I think they really mean "after"] the Physical address is what you need.

Step 5: Notably, once you will be using the Physical address (Host ID), make sure you have removed the dashes/hyphens. This is one of the easiest ways to know the Host ID of your Windows laptop or PCs. Notably, the Host ID's can also be obtained using Linux and Mac OS.

Read more at: https://www.gizbot.com/how-to/features/what-is-windows-10-host-id-how-to-find-it-074055.html

 

 

Link to comment
Share on other sites

I just purchased a subscription (rather than doing a trial), so it didn't ask me to do that. Sounds like something I'd have to do if I renew, though, so curious to see if Rob's tutorial works for you.

Link to comment
Share on other sites

Thanks for your replies Robert and Largento.  I've submitted my request for a trial of A:M following the method Rob suggests.  The Physical address of my Windows machine came up as more than 8 numbers.  I submitted it, but not sure it's going to work.

Link to comment
Share on other sites

As a follow up to your 1st post Largento:

Your screenshots of the anomaly look a lot like the "backward facing polys" option in your rendering settings is not selected and you may have some surface normals facing incorrectly in your model.  I feel sheepish mentioning this since you are a Hash Fellow and know the software much more deeply than I.  You stated that you haven't used the software in a while though, so I'm taking the chance to mention this.

Link to comment
Share on other sites

Haha, I fear I've forgotten nearly all I knew, Chris!

I'm not sure if it's the backward facing polys setting. I don't think that feature ever worked on the Mac version, so it's not one I think I used much. Was it only for rendering? This issue just effects the display of the model while you're using A:M. 

It doesn't appear to be a normals issue, though. I used to spend a lot of time correcting the normals on my old models and since I used Porcelain, they stuck out like sore thumbs when they were flipped.

It happens even with a simple cube.

I think it's probably something to do with how Parallels does Open GL. This same issue was there when I tried using Parallels many years ago, so I don't think it has anything to do with the the new Mac.

Still, it's been fun to be able to open up a bunch of my old models.

 

Link to comment
Share on other sites

The backward facing polys setting works on my MacBook Pro running OS 10.11.6.  In the advanced rendering settings the output should be set to “Shaded” instead of “Final” to see the “Show back facing polys” option to choose “on/off”.  Is it possible that you have that setting “off”?  Rendering on my end isn’t affected by this setting, only in the shaded view of the modeling window.

Link to comment
Share on other sites

17 hours ago, cribbidaj said:

The backward facing polys setting works on my MacBook Pro running OS 10.11.6.  In the advanced rendering settings the output should be set to “Shaded” instead of “Final” to see the “Show back facing polys” option to choose “on/off”.  Is it possible that you have that setting “off”?  Rendering on my end isn’t affected by this setting, only in the shaded view of the modeling window.

I seem to recall that being a setting, but I've looked through all of the options, and can't find it anywhere. I should point out that I haven't noticed any issues with rendering to an image. The problem is in the actual use of A:M. Tumbling around a model, or moving anything, causes the shaded view to fail. It's appearance is similar to it being submerged into an alpha channel. There is no indication that it is patch or poly-based. Instead, it appears to have something to do with the z-depth of the entire model. If it were just reversed normals, I'd expect to see only the incorrect patches disappearing. This looks like a graphics card issue.

Whatever the case, the only real way to work is in wireframe mode. Quick Render can be used to see what it looks like, but shaded and shaded with wireframe views aren't usable.

I'm not really using A:M, though. Maybe you'll be able to figure it out with more use.

Link to comment
Share on other sites

  • Hash Fellow

SHIFT+6 is the keyboard short cut for "Toggle Back Face culling".

However, it sounds like Mark's issue is more involved, something to do with the limitations of Windows on ARM. Now that I know what an M processor is I'm surprised it works at all. It's much different than running A:M on an Intel Mac.

Something to try... is going to Tools>Options>Global and switching the OpenGL/OpenGl3 choice.

Another thing to try... Tools>Options>OpenGL> Inverse Sortorder

I've read that Windows ARM can run typical Intel-based office apps OK but doesn't do well with games... AKA anything with demanding graphics.

It's possible that graphics performance may improve with future Windows ARM releases. It's possible that some future version of Visual Studio may be able to spit out a native ARM version of A:M without drastic changes to the existing code.

Link to comment
Share on other sites

On 2/27/2023 at 9:34 AM, robcat2075 said:

Something to try... is going to Tools>Options>Global and switching the OpenGL/OpenGl3 choice.

Another thing to try... Tools>Options>OpenGL> Inverse Sortorder

Tried both (as well as Shift+6) with no success. I don't think it's a processor issue so much as a Parallels issue. This happened when I tried using it on an Intel Mac a few years ago, too. When I used Boot Camp, it worked fine, but Parallels had this issue.

However it is Parallels is attempting to emulate Open GL, it's not playing nice with A:M's realtime rendering.

Boot Camp is no longer an option with new Macs.

Link to comment
Share on other sites

  • 1 month later...

Parallels uses a really old version 3 ati drivers in their environment, I tried this as I’m in between getting a new rig with only my Mac as a working machine and put am in parallel - if you check the video driver it thinks it using that would be the problem, I think the issue is more license issues with incorporating graphics card drivers in their emulation environment rather than parallels not being able to emulate on Mac iNtel / m1, they would either have to get a license to distribute recompiled versions of drivers rebuilt from closed source code  from either nvidia / amd that and they probably don’t want to invest time and money into it probably 

Link to comment
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...