Jump to content
Hash, Inc. Forums
Shelton

Buying a coffee shop

Recommended Posts

Very nice and smooth spline layout you got there :).

Share this post


Link to post
Share on other sites

Here is a screen shot of where I am at now. The face rig is built so I can import the base to the individual models.

 

Steve

Oooooo...nice user interface for the face rig !

Share this post


Link to post
Share on other sites

Nancy said:

Oooooo...nice user interface for the face rig !

 

I agree!

Is that bone at the top of the UI for moving it to other locations?

That's sure to be useful. :)

Share this post


Link to post
Share on other sites

Yes Rodney the one at the top is for moving and sizing of the face rig of the bones, nulls, and geometry

 

Steve

Share this post


Link to post
Share on other sites

I want to compliment David Simmons, Mark Skodacek, Mack Chappelle, Holmes Bryant and anyone else that has created a rig for our use. Working on just a small face rig for my characters I have found that a lot of work and planning have gone into all the rigs. I also want to say thank you!!

 

David I have so many questions on the face rig. I have answered a lot by digging into your face interface or by trial and error. If you have time you can email me at steves at desdyninc dot biz. I am trying to create the rig based on face poses and activate those poses with the nulls, and thank you for excellent instructions, plus bone movement. There are some other areas that I need help on to finish up this process. I can see this will be a ongoing process as I have found that I think I am about done and then I want to add one more thing ......

 

Steve

Share this post


Link to post
Share on other sites
I want to compliment David Simmons, Mark Skodacek, Mack Chappelle, Holmes Bryant and anyone else that has created a rig for our use.

 

Hear! Hear! I don't think they realize just how appreciated they are!

 

I am trying to create the rig based on face poses and activate those poses with the nulls,

 

That is an excellent idea and a great way forward.

Some don't care for Libraries but if those libraries could be accessed more directly via character/object settings/interface they might appreciate those more as well.

 

I am reminded of ToaA:M's tiny write up on 'Talent Pools' and it applies to real people just as much as it does the labor they produce.

If animation is hard it is mostly because of the many obstacles that must me overcome before animation can begin.

 

I have found that I think I am about done and then I want to add one more thing ......

 

While it doesn't always see us getting to our destination I suppose that is the fun of taking the journey... there will always be one more thing.

 

Thank YOU Steve for sharing your experience. :)

Share this post


Link to post
Share on other sites

Thank you Rodney for the kind words.

What David has done with the squetch rig, in regards to the face rig is incredible. Really for the whole rig is incredible. What Mark demonstrated with his face rig was, well, wow! Holmes' face rig was totally cool as you were in control to add to it.

What i have found is no matter how much i wanted to get away from bones in the face, there is nothing better to give the beautiful motion as the bones do. That being said, the poses created with muscle mode and smart skin in combination with a bone is pretty awesome too. So some of the poses are bone based and some are strictly muscle mode poses. what i am doing is installing the rig in laurie with the poses already created. I will then create a smart skin based on a bone and then transfer the relationship into laurie. On the stand alone face i am creating a rig with a bone and a null with all the poses in place and with the relationship created. Hopefully this will work. Then actually move the mesh or the bone according to to the relationship. I have window for a couple weeks as Chris will be out of pocket for a few days.

 

I did a quick render here and wanted to show that I put a rotate around the head on the face cam of the face rig. I positioned the base at 0 and that allows the face cam to rotate around the head to give different angles rather than move a camera in or add another camera for the angle shots. Others may have done this and it might be old news but I thought it was cool.

facecam0.jpg

Share this post


Link to post
Share on other sites

I positioned the base at 0 and that allows the face cam to rotate around the head to give different angles rather than move a camera in or add another camera for the angle shots. Others may have done this and it might be old news but I thought it was cool.

 

Yessir, the Squetch Rig has that as well.

 

I sent you an e-mail, but I'm not sure if it got through, Steve.

Share this post


Link to post
Share on other sites

I just got it David. I solved several of the mysteries but will send you a few things I am still having issues with.

 

Steve

Share this post


Link to post
Share on other sites

The face rig is finally taking shape. On the left of the head will be the phonems. Still working on linking the poses and bones to the nulls and make sure the limits are correct.

 

I never said this I don't think to the forum, but it is amazing what this program can do. There are so many features that I have not even touch until now.

 

Steve

 

laurieface.jpg

Share this post


Link to post
Share on other sites

Took a little break from the face rig. Working on several things but here is a tree I am working on. 3/4 done and will have leaves when finished

 

Steve

 

 

edit

 

does anyone have a good bark material?

tree.jpg

Share this post


Link to post
Share on other sites

Well AM acting up I lost everything on the tree. project, models, leaves, bark etc...

 

Noticed AM stated temp file at the top of the menu bar. i knew I was in trouble.

 

 

Then blue screen and then rebooted and the file was gone.

 

Steve

Share this post


Link to post
Share on other sites

A bluescreen from A:M? Sure you do not have a RAM-problem? I never had a bluescreen from A:M...

I'd recommend to test your RAM memory just in case...

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

Hi Gerald

 

I had several AM opened as I was working on several projects (5). The blue screen happened when I was making a copy of a branch in the model. When I moved the branch AM crashed, all projects, along with PS and several other things I had opened. Shortly after that the computer went to a blue screen.

 

I have tested the memory and everything appears to be ok no errors were returned.

 

This is what I was working on and applies to the feathers as well. I am trying to make a leaf for the tree. I have a pic I am going by. I changed the the settings time based. But not getting what I need.

 

Steve

 

oak.jpg

Share this post


Link to post
Share on other sites

I was using hair particle system. Would you do it that way?

 

Steve

Share this post


Link to post
Share on other sites

Here's a quick try using the image with just the key color set since it has no alpha....

leaf90.zip

 

settings.JPG

Share this post


Link to post
Share on other sites

Robert. I could not get AM to recognize the pic. I will use your example when i get home. Thanks for looking.

Share this post


Link to post
Share on other sites

The jpg in my zip won't import into your A:M?

 

Or your JPG doesn't work?

Share this post


Link to post
Share on other sites

Sorry when i tried to use a pic earlier today it would not work. I created a new material used your pic and everything is fine.

Share this post


Link to post
Share on other sites

Not that you need the leaf with alpha channel but just in case you do... here is the leaf w/ alpha in exr, png and tga format.

For changing of season/color one could adjust the ambiance color and intensity and get pretty much any color.

Edit: For the heck of it I added an altered color (dying leaf of autumn) version.

leaf0000.exr

leaf0000.png

leaf0000.tga

leaf 2 0000.PNG

Share this post


Link to post
Share on other sites

Thank you Rodney and Robert. Still tinkering with the leaves. Will show some progess later

Share this post


Link to post
Share on other sites

Steve, you asked about bark material...

 

There are two bark materials in the Materials Library (there should be four... not sure what became of the other two... but the other two are variations on one of the two so that might be why they aren't there).

(They are rather understated so will likely need adjustment and/or another version of the material overlaid as displacement or bump). The two materials are the first two materials in the Wood category. (See attached image)

 

I see Jeetman (George Dugas) uploaded a tree model with a more pronounced bark in this topic (as an assist to Gene in one of his projects):

 

https://www.hash.com/forums/index.php?showtopic=35480&page=1&do=findComment&comment=303290

bark in library.jpg

Share this post


Link to post
Share on other sites

If you want to go the Darktree Simbiont route there are some really nice bark materials in that collection:

 

http://www.darksim.com/Repository/tx_Wood/

 

 

You could also render those out on a proxy model and then use the texture image generated from that as decal etc.

 

 

Darktree.jpg

Share this post


Link to post
Share on other sites

Thanks Rodney. Awesome stuff. I am on the road for next couple of days and will check this out this weekend

Share this post


Link to post
Share on other sites

I hadn't used Darktree in so long I thought I should run through the process again and here's a quick render of the results.

Because materials tend to stick to objects in less than ideal angles it can help to first apply the material and then reshape the object to get more ideal results.

For instance, the pattern of of the bark on the roots of a tree shouldn't be of the same angle as that of the trunk.

I didn't take time to resolve any of that in this render.

 

 

barkj tree0.png

Share this post


Link to post
Share on other sites

About finished with this tree. This one was a learning process and now will use it to build another one.

 

Steve

 

two0.jpg

Share this post


Link to post
Share on other sites

Face rig is finally coming together. After a couple of hiccups I am back on track. Hope to upload a video of the process soon

 

Steve

Share this post


Link to post
Share on other sites

I installed 18j and after doing quick render I get this. Also, I have a couple of items with transparency on the model and they are rendering without the transparency settings. Anyone else have this before I put a bug report

quick.jpg

Share this post


Link to post
Share on other sites

By "get this" you mean the diagonal lines, i presume. Is it only on that model or only on that camera? Can you narrow down some circumstances?

Share this post


Link to post
Share on other sites

Yes but since I reloaded the 18j with sse 4 I am no longer getting weird renders.

 

Here is a shot with sss, hair, ssao, and effects added

 

Steve

two0.jpg

Share this post


Link to post
Share on other sites

Thanks Douglas!

 

I am at a decision point on skin and other rendering issues.

 

I am happy with the SSS settings on her, the hair is almost there, now I have applied SSAO and getting soft renders that I like. Once the face rig is in place I will apply her make up. I have a few smudges on the render that what I believe is the transparent apron. I will test my theory later.

 

Steve

 

hands0.jpg

handstwo0.jpg

Share this post


Link to post
Share on other sites

This may be late in the game to say this, but are her eyes too small and/or too far apart?

Share this post


Link to post
Share on other sites

As we begin rendering scenes we are having issues with net render. All the buildings and props are set as action objects, the ability to turn on and off the objects with a pose. The objects render fine in AM but when we send the project to the netrender farm none of the objects render. We also notice that the time to load the files on the net render slaves are way to fast for the size of the project.

 

This is a huge problem. As soon as net render is involved then no rendering of the set is possible.

 

 

Steve

Share this post


Link to post
Share on other sites

Did you write a bug report about it?

The alternative is to open A:M several times on the computer and use for instance the step-property. (means: render every n-frame of the file) or you just divide your rendering into several ranges and render those each...

it is less comfortable, but it will work.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

This is now ticket #6617. I created a simple project and attached it to that ticket. Here is the sample project rendered from within A:M and from within NR. The ears are attached as action objects within a pose; they are inactive in the pose=OFF setting, and active in the pose=ON setting, as I was doing in the tutorial video I'd posted previously here.

In A:M:

AMPoseAction0000.png

In NetRender:

NRPoseAction0000.png

Share this post


Link to post
Share on other sites

While we are looking at the set and issues with netrender, I have been going through the models the last couple of nights and getting them ready for the street scene or the end scene. There is a "lot" of things to do!!

 

Here is a shot of Tony with his hot dog cart and will be on the sidewalk.

 

Steve

 

tony1.jpg

Share this post


Link to post
Share on other sites

He looks ready for business!

 

His forearms seem to have a bend to them that is not quite right.

Share this post


Link to post
Share on other sites

Robert i will look at that issue this afternoon. Good catch.

Share this post


Link to post
Share on other sites

Clean up has begun on all the characters.

 

Stone has received arm and hand rebuild as well as the leg area reworked

Conner has received arm and shoulder rebuild

Angie has received hand sizing and body sizing

Laurie will receive new hair as each new version of her I have to redo the action pose of her hair. I am going to remove her pose hair and groom hair into place.

 

Alot of rendering issues. One character render fine in one setting but all the other characters will have issue. I will change settings and bring one or two into workable renders and then the others will have issues.

 

Rigging continues. Getting ready to install three rigs this week and next. I will be on vacation in a couple of weeks and hope to use some of that time to complete these four.

stone0.jpg

Share this post


Link to post
Share on other sites

All these characters are rigged but going to re do them since i have remodeled the upper bodies. Now i can incorporate the face rig as well

Thanks David!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...