Jump to content
Hash, Inc. Forums
Sign in to follow this  
Pitcher

Restoring functionality to damaged choreography files

Recommended Posts

Well, no mistake about it--I'm a train wreck! I have had two or three issues in the last week or two, and another occurred last night. This time, however, I had the answer, because of the help I received previously. Here's what happened. I use version 15i. It is what I've used since I started in November 2011 when I started into this. I have been working on the same project since then and was afraid to change because I want it all to look consistent.

 

Yesterday, I was updating a file I did about two years ago trying to make it better. It is a scene that is so large that I can only look at it occasionally in shaded or shaded and wireframe. It will not go from frame to frame in real time in either of those. I also frequently have to click on something and wait for computer dynamics to calculate for a minute or two (or however long) before I can move a bone or a control point. Frequently, it won't show me where it moved it to until after it computes dynamics again for a minute or three. In other words, it is horrendous to work on this file. There are 21 participants in the scene that has a background with various buildings.

 

I rendered the file to get a look at it, so I could go back and fix various problems. During the next six or eight hours, I fixed as many as I could. I backed up frequently to keep from losing my work. It became late, and I decided to render again while I slept. Then, to my horror, I found that the file would not render. It would load, and it was viewable on a frame by frame basis in wireframe, shaded, and shaded and wireframe, but it would not do a final render or a temporary render. I noticed then that Windows had updated and that Java wanted to update. I let Java update because I worried that somehow the old Java had gone bad. It didn't help. I did a System Restore to an earlier happier time, but that didn't help. I tried to render another file to see if it was just this file or every choreography. The other choreography rendered just fine. Horrors! A corrupted file! Would it ever render?

 

Then, I remembered an earlier difficulty I had yesterday (or last week) when a choreography would view fine, except that front view was upside down. Fuchur had given a wonderful piece of advice there about importing the choreography into another choreography. I tried that on this file, and it worked! The file would render!

 

There were a few problems, however, that I should mention. There were a new camera, a new rim, a new ground, a new fill light, and a new key light. My old ones were there also and were called 2 (e.g., Camera2). The new versions were causing me to lose my camera and light settings. I could have looked them up on my records or in the file itself and reinserted them, but one-by-one, I moved the old ones above the new ones and omitted the new ones. (As I did this, I kept checking to see if the file would still render and if I could still save it under a new name. One time, before I moved the old ones above the new ones, I omitted the new ones, and the file would not save. That's why hierarchy is important here.Maybe, it's always important.) Now, I basically have the old choreography file, but it will render.

 

It took an hour or so to go through all of the recovery attempts, but it would have been much more difficult to start again on the changes I had made. I wanted to throw this out there to thank Fuchur again for the earlier information and to show how this Forum really helps. I also thought someone might someday have a choreography file that won't render or that might have lost part of its functionality in another way. Here is another thing to try.

 

I want to thank every else who has offered advice and support also. I highlighted Fuchur here, because his advice directly led to this solution.

Share this post


Link to post
Share on other sites

;) thanks for letting us know about that and of course you are very welcome :). always good to know that some of the rubbish i am typing is actually useful to somebody :).

 

see u

*fuchur*

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...