Jump to content
Hash, Inc. Forums
Sign in to follow this  
JohnArtbox

Hair

Recommended Posts

I've played with Hair a few times and then put it back in the box because i could never get it to work. So I tried again today and it worked perfectly, until I turned motionblur on. The first subframe renders perfectly but then the geometry moves while the hair stays static on individual frames, causing it to intersect the geometry. I ran some tests by rendering without motion blur, with motion blur, with motion blur added in post(the best option), and lastly by rendering at 120fps without motion blur and then combining frames to create motion blur manually. The last option works but seems to add extraneous jitter to the hair, although this may just be my settings.

So does anyone have any advice on hair, or can you confirm that my surmises are correct.

The movie shows all of the tests labelled

HairTest.avi.mp4

Share this post


Link to post
Share on other sites

-Have you tried "baking" the hair before the render? "Bake Particles" I think.

 

 

-Remote possibility.... the way multipass is incremented has changed in v18f. Do you get the same wrong result in v17?

 

 

-Another option is A:M's non-multipass motion blur which should be similar to your AE post motion blur

Share this post


Link to post
Share on other sites

A brief test I just did with a transparent emitter suggests that the roots of the hair are being properly moved in subframes, but not the rest of the hair. so the hair is stretched in a trailing direction.

 

 

The hair is on a transparent dome and moving from left to right....

 

hair003.jpg

Share this post


Link to post
Share on other sites

Motion blur in 3D applications seems to be a problem that effects them all, not just A:M. That's why 3rd party post effects like Real Smart Motion Blur are popular solutions.

http://www.revisionfx.com/products/rsmb/ $150 is a LOT for just a motion-blur solution... especially when AE offers a few solutions included- as you have experimented.

 

I've been playing with A:M's hair feature for a good decade now... I've looked at other 3D packages but keep coming back to A:M and toying with Hair and in particular it's collision-detection ability- ever experimenting with the range of settings looking for the right combination. HERE is a tip I'd like to get some input on that may or may not help:

 

SEE IMAGE: In the choreography's properties, set the gravity (Y force) to zero- instead, set this 'downward' value in the hair's own property... I am currently using a value of -200. Next, bump the 'Rigid Subsamples' and 'Rigid Drag' values way up from default settings. I'm not sure what these settings DO, but I am fishing for the inter-frame collision-detection ability. Since dynamic hair is RESPONSIVE to the action that drives it... it is also VULNERABLE to those same actions, meaning- the relationship of the hair to geometry can be FINE on frame 1, but on frame 2 the geom can MOVE to where the hair IS, and the hair would have no chance to REACT properly... so inter-frame 'checking', and the more-the-better- is needed. (An example of this occurs in your sample where you have the problems, the head moves UP in space to where the hair is, giving the hair no time to react so a 'pass-thru' happens until the hair can catch-up.)

tempry.jpg

Share this post


Link to post
Share on other sites

raising rigid subsamples and rigid drag doesn't get me a different result. The root of the hair is being moved in subframes but the tip (and I presume all intermediate CPs) are being left in place.

 

hairB003.jpg

Share this post


Link to post
Share on other sites

Does that hair have the dynamics option turned ON and set low enough to be reactive to the motion?

Share this post


Link to post
Share on other sites

Thanks guys

Robert, I tried baking particles without success, I'll try rendering in 17 to see if it makes a difference. the a-buffer motion blur is significantly worse than the AE option as it only operates on the model patches and ignores the hair. As for the interpolation I think the hair points are stagnant but the points that are attached to the patches move with them, hence the stretching.

Matt, tried your settings without success. Increasing the two values didn't seem to affect it, and there seems to be no sub-frame interpolation on the hair.

I'm having reasonable success with various settings on non-motion blur renders, now I'm just working my way through all the different options to try and work out what they all do, and which ones work.

Is there a comprehensive outline of hair settings anywhere?

Share this post


Link to post
Share on other sites

There have been several attempts to dig deep into particle hair but all of that information has never been compiled.

 

I'm currently collecting what can be found and shared in 'The Hair Salon'.

Share this post


Link to post
Share on other sites

John- thinking again about the 'subframe calculations' needed to ensure that moving objects do not infringe on the hair's space... I remember once being informed here on the forum by a Hash programmer (THOSE were the days!) that there was a method to get the app to do the between frame checking- I THOUGHT it was the 'rigid subsamples' setting, but you and I have experimented with that and concluded NO... maybe it can be done this other way:

 

Setting your project's FPS to something HIGH, say 10X your goal frame-rate, and then rendering only every X frame- where 'X' is what you multiplied by... SO- if your goal frame rate is 24 frames per second, then you would set it to 240 fps, then render every 10th frame in the render settings. This might get A:M to calculate 9 extra steps in-between each frame, ensuring frame by frame that the hair does not get infringed upon by geometry that wants to be in the same space...

Share this post


Link to post
Share on other sites

NEVERMIND- tried it(above idea) on my current A:M Hair CD project with disastrous results.

 

I think in regards to you're initial question (motion blur on hair) that, like other particle generated effects (sprites, fluid, blobbies) A:M's hair feature lies outside of the motion blurs engine.

 

On the attached image you can see my results, the motion blur should be the same on the hair as it is on the geometry- but there is no indication of it at all.

tempry3.jpg

Share this post


Link to post
Share on other sites

Rodney, thanks for that very useful link.

Matt, I thought the same, although maybe it was the cloth solver. The hair salon proved useful, but do far the most useful solution seems to be to use keyframes to judiciously pull the hair back into position, and to use styles that minimise the issues. I'm going to pull apart the project you posted to see what else I can learn.

Share this post


Link to post
Share on other sites

John- Looking at your 'HairTest.avi' again with regards to the collision-detection, the setting(s) I would adjust would be to the 'Angle Limit' setting... this defaults to 180 which gives the hair too much 'free reign'. With the angle limited, the hair is pointed away from the emitting patch in the direction of the normal... to a degree. Try a setting of 45degrees, and if that makes the hair too 'stand-uppish' you can add more Control Points- which makes the hair more 'spaghetti-ish'- with the intended result of both settings to be to point the hair away from the mesh- but let it be bendy enough where it would fall back more along it's length. Kinda like a real hair-follacle, it is more brittle and rigid at it's base as it emits from the pore- and more curvable/bendy toward it's reach... ALSO- adding more Control Points aids the collision-detection ability. Don't go too high on a short hair like that... maybe 4 or 5. The new A:M 18 allows up to 30 of these Control Points along the hair's length- but at that amount the hair becomes very 'stretchy' and 'springy'... not good!

 

CHECK THE HAIR SALON FORUM AGAIN TODAY... MORE GOODIES!

Share this post


Link to post
Share on other sites

There is a hair emitter property for jitter. This setting renders the hair in subframes so you could lower the density. This may help you with the motion blur issue.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...