Jump to content
Hash, Inc. Forums
Sign in to follow this  
johnl3d

poses acting even when off at start up

Recommended Posts

Okay was playing with expression assigned to pose

 

got this qucik result

 

rand1.mov

 

now however when I try to place the model in a new project/chor it acts as if pose is on even though its off in model and chor area

 

 

can someone try to place rbird.mdl into chor and position it and see if it misbehaves

 

:blink:

Share this post


Link to post
Share on other sites

I tried it. It jumps around even when the poses are OFF.

Share this post


Link to post
Share on other sites

David that allows the model to be placed in the chor but it could not be placed anywhere in chor window at least when I tried

Share this post


Link to post
Share on other sites
David that allows the model to be placed in the chor but it could not be placed anywhere in chor window at least when I tried

 

I'm thinking it would require adding a positioning bone in the Choreography and replacing the "0" in the "If()" statement to the XYZ of that positioning bone. Then, while the Pose is off, you would be able to move the object using the positioning bone.

 

I can't put an example together until late tonight, but, hopefully I explained it adequately.

Share this post


Link to post
Share on other sites

Try this John.

 

I added a root bone to the dynamic chain and set the expressions to that bone. Now you can move the model anywhere in the chor. (bones with expressions can not be animated)

 

I also set the poses to "not set" in the user properties of the model. This is the only way to turn OFF expressions, this can not be animated in the chor. If you want to animate the pose, another bone and pose will be needed. (new bone, same hierarchy as root bone, expressions set to that bone instead. new percentage pose, root bone "translate to" the new bone with expressions)

rbird_fix.mdl

Share this post


Link to post
Share on other sites

That did it except I rotated the root bone 90 degrees to keep the birds above ground once they started to "dance" after setting them in position with pose 1 off

 

 

rbird_fixed.mdl

 

 

rand1fix.mov

 

 

Thanks for looking at this and solving the issue ..back to tinkering :lol:

Share this post


Link to post
Share on other sites

Oops, forgot to check the roll handle on the root bone. Just set the z rotation to 0 in the bones properties.

 

You don't need the pose off to move the model bone, so you can actually animate the models positon to give it even more randomness.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...