Jump to content
Hash, Inc. Forums
Sign in to follow this  
bubba

Render to file background question

Recommended Posts

Why is the background to my choreography different when I render-to-file than when I am working with the choreography?

 

This is my working screen.

 

Screen_shot_2011_02_26_at_8.02.47_PM.jpg

 

This is the rendered file.

 

Walking_Lower_Body_F1.mov

Share this post


Link to post
Share on other sites

"Animation" codec in quicktme supports an alpha channel and you got one.

 

In "buffers" in your render settings turn Alpha OFF.

Share this post


Link to post
Share on other sites

Unless you really need to render huge Quicktime movies with alpha channels, I would suggest rendering to h264 codec and playing with the bitrate until you find a good compromise between file size and quality.

 

For your test renders, limit the data rate to 1200 KB/sec or less.

For your final render, render out to individual tga or png frames for best quality and to prevent you from having to rerender that entire sequence if something happens (power outage, crash, whatever).

 

Animation Master can import the image sequence you rendered, add your audio to it and render a quicktime movie with the audio.

 

Make a new Project.

Import your image sequence.

Import your audio.

Make a new choreography.

Drag your image sequence onto the camera in the choreography (as a camera rotoscope).

Add your audio to the choreography.

Render movie.

It will render much faster than the original 3D scene because A:M is just processing the 2D images and audio.

Share this post


Link to post
Share on other sites
Unless you really need to render huge Quicktime movies with alpha channels, I would suggest rendering to h264 codec and playing with the bitrate until you find a good compromise between file size and quality.

 

 

HomeSlice,

 

How do I set up Quicktime to render in the h264 codec. Nothing I can find in the render dialog box would allow me to do so.

Share this post


Link to post
Share on other sites
"Animation" codec in quicktme supports an alpha channel and you got one.

 

In "buffers" in your render settings turn Alpha OFF.

 

 

Walking_Lower_Body_S1.mov

 

When I look at this short clip with QuicktimeX on my desktop all I see is the brown ground, black background, and green line around the model. Why it displays correctly when I view it on line is way beyond my simple understanding.

Share this post


Link to post
Share on other sites
"Animation" codec in quicktme supports an alpha channel and you got one.

 

In "buffers" in your render settings turn Alpha OFF.

 

 

Walking_Lower_Body_S1.mov

 

When I look at this short clip with QuicktimeX on my desktop all I see is the brown ground, black background, and green line around the model. Why it displays correctly when I view it on line is way beyond my simple understanding.

 

That one is in Animation Codec again with an alpha channel, possibly because it was rendered with "Millions +".

 

i see brown ground, green sky and the walker model.

 

Choose a different codec in your render settings under Format>Save Options>Set

Share this post


Link to post
Share on other sites

Please render to TGAs, PNGs or JPEGs first and after that use A:M or Super or some equal software to produce the final output.

That can be done by importing the image-sequence and export that as a video-file from A:M.

 

It will help you with many problems, will produce solid and reusable results and you won't loose anything when the rendering aborts at some point.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites
Unless you really need to render huge Quicktime movies with alpha channels, I would suggest rendering to h264 codec and playing with the bitrate until you find a good compromise between file size and quality.

HomeSlice,

How do I set up Quicktime to render in the h264 codec. Nothing I can find in the render dialog box would allow me to do so.

I don't know how it looks on a Mac, but here is a screenshot from WinXP.

 

After you render the movie in AM, open it in Quicktime Pro and export it with the same settings (from Quicktime Pro), except for audio choose AAC for the codec. This will make the file size even smaller with only a marginal loss in quality.

This will be good for quick test renders and for short renders you want to share on the internet.

For your final rendered piece, follow Fuchur's advise.

change_codec.jpg

Share this post


Link to post
Share on other sites
Animation Master can import the image sequence you rendered, add your audio to it and render a quicktime movie with the audio.

 

Make a new Project.

Import your image sequence.

Make a new choreography.

Drag your image sequence onto the camera in the choreography (as a camera rotoscope).

Render movie.

It will render much faster than the original 3D scene because A:M is just processing the 2D images and audio.

 

I followed your instructions but here is what I get.

 

First the opening TGA:

 

Walking_Lower_Body_S0000.tga

 

Now the movie:

 

Warhawksequence.mov

 

The two bear no resemblance to each other.

Share this post


Link to post
Share on other sites

I'm not sure if that image (the tga) is supposed to be the first image in your sequence of tgas - but I will assume it was. I am also not sure why you are re-rendering a rotoscope from a chor, rather than importing the image sequence, and then right clicking (or whatever macs do) - and then saving the image sequence as a qt movie from A:M or even doing it in QT pro.

 

However, lets assume you have a reason for rerendering the roto from a chor. Can you post a screen capture of the the chor that shows the image sequence is a rotoscope for the camera. I also suspect you will have to set the ground plane to front projected, flat shaded as well. Or else make the ground plane inactive. Or set the rotoscope to ON TOP.

 

Has it been acknowledged yet from others that Macs have a problem with whatever you are trying to do? in whatever version you are using? (I have not closely followed this topic).

 

EDIT: - I see why you might be rerendering, you are trying to add audio. Did you also add the audio to the chor that you are rerendering with?

Share this post


Link to post
Share on other sites

Thank you Nancy. I am so new to A:M that I don't know all the "ins and outs" yet. At the present time I am not trying to add audio, but perhaps sometime in the future.

 

This whole topic was about seeing different backgrounds when I rendered. It came down to rendering out a sequence, not a movie. So I used the Netrender from v16 to create the sequence then brought it into A:M to render out to a movie. The RMB "Save animation..." worked great!

 

But it still begs the question of what happened to the rendering from the chor?

 

Yes the tga is the first of the sequence. I am using v15 because of acknowledged issues with constraints in the Mac version of v16.

Share this post


Link to post
Share on other sites
Thank you Nancy. I am so new to A:M that I don't know all the "ins and outs" yet. At the present time I am not trying to add audio, but perhaps sometime in the future.

 

This whole topic was about seeing different backgrounds when I rendered. It came down to rendering out a sequence, not a movie. So I used the Netrender from v16 to create the sequence then brought it into A:M to render out to a movie. The RMB "Save animation..." worked great!

 

But it still begs the question of what happened to the rendering from the chor?

 

Yes the tga is the first of the sequence. I am using v15 because of acknowledged issues with constraints in the Mac version of v16.

It looks to me that the chor that was used for rendering the sequence (with netrender) used a different camera setting (eg background color, angle, aim) than the chor that was used when trying to manually render using the resultant tga sequence. This shouldn't matter, as you were just trying to add a roto.

 

It looks like you didn't add a rotoscope to the camera when you manually tried to rerender with the tga sequence as a rotoscope. Check out Roberts video. Unfortunately he is rendering to an avi, and doesn't use a tga sequence. But the basic adding a rotoscope to the camera is what he's demonstrating.

 

And if you are really new to A:M, it would probably help to render while testing to much smaller resolutions - by just halving the resolution, your render time will probably be cut to 25% of the time. i.e 5 secs/frame is better than 20 secs. Then reup the resolution after you have tested. It will speed up your learning process.

Edited by NancyGormezano

Share this post


Link to post
Share on other sites

Hi Nancy,

 

Can you point me in the direction of the "Roberts video." I did a search on rotoscope but jumped out at me. And I believe there are several Roberts. Thanks.

Share this post


Link to post
Share on other sites
Hi Nancy,

 

Can you point me in the direction of the "Roberts video." I did a search on rotoscope but jumped out at me. And I believe there are several Roberts. Thanks.

 

Ah, you missed it...it's hiding just a coupla replys up in this very thread here

 

Essentially, in the chor, and assuming you have imported your sequence, right click on the camera and choose new/rotoscope/"your sequence"

 

(Alternatively, Robert drags & drops the sequence ontop of the camera)

 

After you have chosen a camera rotoscope, then open the properties for the rotoscope and set ON TOP = ON.

 

You can set your render settings, (frame range, resolution, file name, file type, compression, etc) in the camera at this point, then render to file. Or set the render settings in the dialog box that pops up when you go to render. Check that all is correct before hitting ok.

newrotoscope.jpg

newrotoscope2.jpg

Share this post


Link to post
Share on other sites
And I believe there are several Roberts.

 

 

Imposters!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...