Jump to content
Hash, Inc. Forums
Sign in to follow this  
itsjustme

Gamma discussion

Recommended Posts

The subject of Desired Gamma came up and I was unable to get my software to cooperate at the time, so, I made an attempt at a video explanation of the little I know that I am posting here along with the Projects used and renders.

One thing I still don't think I got across in the video is that if you are working with 2.2 gamma images, the gamma correction can get re-applied automatically with each iteration causing the image or portion of image (and colors) to lighten.  Anyway, here is the video and Project files.

Hopefully, it is helpful.

 

 

Desired_Gamma_testing.zip

Share this post


Link to post
Share on other sites

I did some more digging and found info on Desired Gamma here (a page from Yves' website using the Wayback Machine).  The paragraphs that apply are these:

 

Quote

I don't know about all the 3D CG applications but I will take Animation:Master as an example. In the "Tools" menu, "Options", "Rendering" tab, there are two settings for adjusting the gamma of the "Preview renders": "Desired Gamma" and "Current Gamma".

The "Current Gamma" setting can be set with the help of the embedded gamma chart. The display monitor should arleady be set with a gamma 2.2 but the provided gamma chart will allow adjusting the preview renders to work correctly with whatever prefered gamma setting.

The "Desired Gamma" should be set to whatever gamma correction that is planned to be applied as a post processing on the rendered output files. In the context of the tone correction tutorial, this should be set to "2.2".

The default values for those settings are Desired Gamma: 1.0 and Current Gamma: 2.2. This setting will actually apply no gamma correction at all to the preview renders no matter how your workstation gamma is actually set. In the context of the current Tone Correction tutorial, those settings should be set to 2.2 in both cases.

 

This would mean that the "Current Gamma" should be set to the gamma of your monitor (which should be 2.2 for everyone).  Then, the "Desired Gamma"  is set to the gamma correction planned...which, if rendering to a 1.0 gamma OpenEXR, needs to be 1/2.2 according to this illustration (found on this page):

gamma.svg

 

Reading Yves' description, I would assume this correction for a 1.0 gamma would be applied when "Desired Gamma" is set to 1.0, but that doesn't work for me...I get a white screen.  It does appear to work if I set the "Desired Gamma" to 3.4.  I've been using 3.3, but if it's supposed to work at 1.0 there would be a difference of 1.2 and that would be 3.4 (going in the opposite direction).  So, I'm thinking that "Desired Gamma" may be working, but in the opposite direction as intended?  Well, as long as it works.

Share this post


Link to post
Share on other sites

The disconnect between the explanations and my practical results has always confused me.

FYI,  when I use the "Current Gamma" tool in the Render Options I find that my Cintiq is about 1.8 while my rather bargain LCD monitor is more like 2.2

Share this post


Link to post
Share on other sites

If "Current Gamma" is about making the preview renders appear in a certain way then i should at least be seeing a wildly different on screen appearance between the highest and lowest possible settings for "Current Gamma."

I can't see any difference in the appearance of the gray scale produced by a 100% "soft" kleig light at either end of the settings.

Share this post


Link to post
Share on other sites
11 minutes ago, itsjustme said:

Here's what I get:

I don't get anything like that.  It looks the same either way.

Share this post


Link to post
Share on other sites

Mine was acting up during Answer Time, but when I set the Gamma in the Rendering tab (Tools/Options/Rendering/Gamma) to "Custom" and "1" it started behaving itself...not sure why, I'm assuming it needed to be set to something now.

Share this post


Link to post
Share on other sites

Doing the "Custom" and "1" gets me some change but now everything is either very very dark or totally black.

Even if i go back to "none" I can't get back well-balanced range of light to dark I had before.

Share this post


Link to post
Share on other sites

Yup, that got it back.  But why is there no combination of settings that will produce a normal display?

Don't worry about it tonight. It will make a fruitful LAT topic.

Merry Christmas , David!

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...