Jump to content
Hash, Inc. Forums

Recommended Posts

As mentioned elsewhere, have been having a lot of tech troubles recently, had thought they were behind me now and to get on with something new(ish) but have hit a problem with alpha channels in TGA files.

 First a bit of background.

I'm working in V18 within OSX 10:8.5. on a Mac mini, I7, 2.3ghz with 4Gb of  Ram.

Just rendered two scenes to TGA  with the figure set against an empty background ( ready for compositing later ). All was well until I opened them in Photoshop, to find that the background had rendered as black rather than transparent. When selecting the  background and deleting it, the Alpha transparency is there but, ideally, don't wish to do that for 1000+ frames. Is there a setting I  could easily have missed  that might cause this problem ?

Thank you for listening

simon

 

 

ps

Initially the files were rendered to png's but, V18, OSX 10:8.5, produced  incorrectly parsed files. Although they looked correctly rendered when they were going through, when opened afterwards in PS The files were a corrupted incoherent jumble of pixels and PS flagged the message, "cannot open the file because it is  incorrectly parsed.'

This problem had occured before  but, rendering on a different machine/OSX solved it. Unfortunately that option is no longer available due to the recent troubles.

Any suggestions as to how it might be possible to fix this would be very welcome. The prospect of manually removing 1000+ frames backgrounds is not a happy one!

Share this post


Link to post
Share on other sites

Could you send me one of the unedited TGAs?

Transparency in PNG and TGA appear differently in Photoshop.

 

Share this post


Link to post
Share on other sites

Robert

Thank you for your reply and offer of help.

I'll send a copy  of the files  tomorrow if thats OK?.

I've found a work around in Photoshop using Droplets  to do the grunt work.

Its getting late here  and the  the land of nod beckons.

regards

simon

Share this post


Link to post
Share on other sites

As soon as you can! It's just one TGA. Why wait? Just post it here.

In a TGA there is no such thing as a transparent background. There will always be some value in the RGB channels (probably 0,0,0).

The alpha channel will male it transparent in the video editing/compositing program you are using. Why bring it into Photoshop at all?

If you bring this to Live Answer Time tomorrow we could make sure we are talking about the same thing and solve this in five minutes.

Share this post


Link to post
Share on other sites

Robert

Apologies for delay, I have a  large render going through of the full scene, taking 18mins per frame.Rendering at UHD because I want the  larger  file siz to work on afterwards.

Here are the files and a screenshot of the  settings used  in the render options.

as you can see, the tga file is viewable  but, the same  frame rendered as a png file, is scrambled.  Both file formats were visible when  viewed in the render window in AM as  the render went through, but Photoshop could not read the png file when I tried to use  that to view it..

Thank you for your help.

regards

simon

 

 

 

 

 

TLC S2 0000.tgaScreen Shot 2019-05-25 at 11.53.45.png

Share this post


Link to post
Share on other sites

The TGA has a proper alpha channel. When i put it over another image in a compositing app, it appears to appropriately mask the black background.

Tell me more about why you are putting these in Photoshop, which is not a video compositing app.

SimonComposite.JPG

Share this post


Link to post
Share on other sites

If you want to come by Live Answer Time in a coup[e hours this would be interesting to look at.

Share this post


Link to post
Share on other sites

Robert.

Thank you for your help. Pardon me, I missed the invite to  live answers, I was working on  the short its for.

I tried it in Photoshop because, when I opened the sequence in TVpaint, which does use alpha channels to layer composits, it appeared to be black and not transparent. Will try it in After Effects tomorrow to see how that gets on with it?

Thank you.

regrds

simon

Share this post


Link to post
Share on other sites

Since your TGA works correctly for me I will guess that your After Effects has "Ignore alpha" set as a default.

I would check that immediately.

 

AEPref.JPG

 

Share this post


Link to post
Share on other sites

Thank you  Robert. I shall check that after  having a large cup of tea.

regards

simon

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...