Jump to content
Hash, Inc. Forums
bighop

walking cycle just a little off

Recommended Posts

Hello All,

 

I made a simple character consisting of pieces of chalk and a chalkboard eraser. I'm a teacher and I'm using this as a "Bug" intro to a video my class will be doing later this year.

 

Anyway...

 

I created a simple walk cycle 24 frames.

I made a path and constrained the eraser to it

Assigned the action.

Extended the Cycle length to 15 seconds

 

The character walks ok, but it will glide for about two frames at the end of the cycle, and return to his walk cycle and glide at the end again. I did set the stride length, but I must be missing something. It's bugging me because when the character walks, you can see there is just something not right, because the glide is very slight.

 

Any ideas anyone?

 

Thanks

Share this post


Link to post
Share on other sites

Hi Bighop,

 

The glide is happening because the timeline is longer than the walkcycle animation. If you look at the keys you'll see a red bar on the dopesheet (the dopesheet is where all your keys are shown). You need to extend the red bar by dragging it out to match the timeline.

 

Example:

 

If your timeline is at say 02:00 and your walkcycle animation "red bar" is under that by 4 frames at 01:20, then the model will appear to slide with arms out from 01:20 to 02:00.

 

I hope this helps,

George

 

 

Edit: I just reread your post. Check the timeline bar. It's the blue bar at the top. Make sure it extends to the length of your timeline too.

 

Hello All,

 

I made a simple character consisting of pieces of chalk and a chalkboard eraser. I'm a teacher and I'm using this as a "Bug" intro to a video my class will be doing later this year.

 

Anyway...

 

I created a simple walk cycle 24 frames.

I made a path and constrained the eraser to it

Assigned the action.

Extended the Cycle length to 15 seconds

 

The character walks ok, but it will glide for about two frames at the end of the cycle, and return to his walk cycle and glide at the end again. I did set the stride length, but I must be missing something. It's bugging me because when the character walks, you can see there is just something not right, because the glide is very slight.

 

Any ideas anyone?

 

Thanks

Share this post


Link to post
Share on other sites

Jeetman is right. Did you check your timelins bar?

That should do it.

Keith

 

 

 

 

 

 

 

Hello All,

 

I made a simple character consisting of pieces of chalk and a chalkboard eraser. I'm a teacher and I'm using this as a "Bug" intro to a video my class will be doing later this year.

 

Anyway...

 

I created a simple walk cycle 24 frames.

I made a path and constrained the eraser to it

Assigned the action.

Extended the Cycle length to 15 seconds

 

The character walks ok, but it will glide for about two frames at the end of the cycle, and return to his walk cycle and glide at the end again. I did set the stride length, but I must be missing something. It's bugging me because when the character walks, you can see there is just something not right, because the glide is very slight.

 

Any ideas anyone?

 

Thanks

Share this post


Link to post
Share on other sites

Great tips, thanks. I double checked that but still it slips. The character walks, but at the end of every walk it glides for two frames and the walk continues.

 

Again it is very slight, just enough to make look at it and go...hmmmmm

Share this post


Link to post
Share on other sites
Great tips, thanks. I double checked that but still it slips. The character walks, but at the end of every walk it glides for two frames and the walk continues.

 

Again it is very slight, just enough to make look at it and go...hmmmmm

 

Posting the Action might help in diagnosing the problem...the entire Project would probably be better though.

Share this post


Link to post
Share on other sites
Will I was trying to avoid this......here is the project file.

 

Thanks,

 

Sorry it took me so long to get back to this...the Project file is missing the "Room112bug_final.mdl" model and the "short_walk_twist.act" Action, so I can't tell if there would be any slippage while the character walks. About all I could tell is that the path works fine.

 

If you post the missing stuff, I'll take another look at it.

Share this post


Link to post
Share on other sites

GOT IT! I finally figured it out! The stride length for the BACK was off, this was causing a two frame slip. I was adjusting the front. what a pain! Now I know.

Share this post


Link to post
Share on other sites
GOT IT! I finally figured it out! The stride length for the BACK was off, this was causing a two frame slip. I was adjusting the front. what a pain! Now I know.

 

Very cool, Andy! The stuff that drives me nuts usually ends up being something simple that I overlooked. I'm glad you found the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...