Jump to content
Hash, Inc. Forums
Sign in to follow this  
robcat2075

Difference in cloth sim times

Recommended Posts

I'd be curious to have people try this SimCloth PRJ on both v18 and v19

 

RMB in the chor and choose Plugins>SimCloth Simulate

 

How long does it take to simulate the first 4 seconds?

 

hammock Test 05 unsimmed .prj

 

 

Share this post


Link to post
Share on other sites

The first four seconds of the timeline took approx 2 minutes and 43 seconds to write out keyframes on my system with Win 10 and v19.

v18 pending...

 

When attempting to open in v18 I get an error stating the Project was created in v19 and then a texture is removed.

I must assume that the Simcloth material is altered.

Then I go to simulate the simcloth in the Chor I don't see the option.

 

In attempting it again I get two error dialogs. The first stating that the project was created in v19 and may not open correctly in v18.

The second (attached) states the Simcloth texture cannot be found.

 

 

Simcloth texture not found.png

Share this post


Link to post
Share on other sites

V19 - 3m15s

 

v18 - 25s

v17 - 23s

 

v17-18 - After the 30th frame there is no indication of frames

Share this post


Link to post
Share on other sites

I pointed both v18 and v19 to the v18p Textured folder and results were:

 

v18 - approx 30 seconds

v19 - approx 3 minutes

 

These times are very rough but there was a very noticeable difference.

Simulating in v18 was noticeably faster.

 

I haven't tried to repoint both v18 and v19 to the v19 simcloth.atx...

There is a noticeable size difference between the two simcloth atx files; 238kb and 263kb respectively.

Update: pointing v18 and v19 to both directories (v18p and v19) allows simulating with both plugins and the results are the same (fast with v18 and slow with v19). So something in v19 is processing the simulation differently.

Share this post


Link to post
Share on other sites

 

In attempting it again I get two error dialogs...

The second (attached) states the Simcloth texture cannot be found.

 

 

 

that's unusual. That suggests that the SimCloth.atx file is missing from your "Textures" folder"

 

 

 

 

V19 - 3m15s

 

v18 - 25s

v17 - 23s

 

v17-18 - After the 30th frame there is no indication of frames

 

 

Prior to v19, the A:M screen would freeze (but continue working) during simulations if some onscreen event happened in some other window on the computer.

 

That was fixed in v19, but I wonder if that fix is the cause of the new delay?

Share this post


Link to post
Share on other sites

Hardly, since from the very beginning the symulating (v19) is slow

Share this post


Link to post
Share on other sites

And how is the result? Is it the same or is it better for v19? Maybe it is more precise now and can handle harder situations but needs more time for that? (would be okay for me... ;))

Share this post


Link to post
Share on other sites

Hardly, since from the very beginning the symulating (v19) is slow

 

 

I believe the screen refresh is forced on every "sub step" so if it is the cause it would happen from the very start.

 

 

 

And how is the result? Is it the same or is it better for v19? Maybe it is more precise now and can handle harder situations but needs more time for that? (would be okay for me... ;))

 

For this test the result appears identical. AFAIK, no changes in precision have been made to simulations for v19.

Share this post


Link to post
Share on other sites

Steffen has found and fixed the problem and now v19 simulates faster than v18. :)

 

Hooray for Steffen!

Share this post


Link to post
Share on other sites
Steffen has found and fixed the problem and now v19 simulates faster than v18.

 

Nice!

 

Faster eh? :)

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...