Jump to content
Hash, Inc. Forums
Sign in to follow this  
dailan1

quick bone question

Recommended Posts

I'm having issues with a rig i put on a character.... specifically (believe i mirrored bone plugin after using the 2001 rig as a base) my right forearm can rotate in all three axies... however my left forearm can only rotate in the y-axis (or the green circle). I can not figure out how to fix this and really don't want to have to start from scratch. Can anyone give me a hint or clue??? Thanks for your time

Share this post


Link to post
Share on other sites

Do you mean that other rings are not visible?

 

First I'll note that it is typical in rigs for the forearm to be set to rotate on only one axis, because... elbows only rotate on one axis.

 

One way to control this is in the bone's properties under Manipulator Options.

 

"Manipulation" can be set to "Translate only" or "Rotate only" and "Limit Manipulators" lets you make the controller for each axis unavailable.

 

BoneProps.JPG

Share this post


Link to post
Share on other sites

Thanks for your help! All the rings are visible and even display the number of degrees when I try to move them, the bone just doesn't go anywhere. I've checked the properties and compared them to the other forearm and they are they are set to the same values. Could it have something to do with a smart skin or a constraint?

Share this post


Link to post
Share on other sites

Could it have something to do with a smart skin or a constraint?

 

A constraint is a possibility also. If you wanted to send me the character in a PM i could look at it.

Share this post


Link to post
Share on other sites

thank you for your offer and I may take you up on that, but I wouldn't want to put you out just yet... I may just try to use the rig again and see how that goes.

Share this post


Link to post
Share on other sites

so just a quick update... i opened the 2001 rig without a model and created a new action... the right forearm on the rig can free rotate, however the left cannot... so either my library is corrupted or the there's a glitch in the rig. i opened some of the other models and decided to just use fan bones and smart skin to prevent the wrist from deforming

Share this post


Link to post
Share on other sites

I'd have to see the specific case to know more. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...