Jump to content
Hash, Inc. Forums
SpaceToast

All Realtime Textures Broken on Macs with Nvidia Cards

Recommended Posts

All realtime rendering of image files is broken in 18.0p Mac on machines with Nvidia graphics cards.

 

 

DrPhibes reported a portion of this issue back in August and markw helpfully pointed out that he'd isolated it to Macs with Nvidia cards, but it's more severe than that report suggests. I've tested the following:

 

-Targa (32bit, with & without alpha channel)

-PSD (multilayer with transparency, single layer with transparency, single layer with alpha channel, single layer without alpha or transparency)

-PNG (with & without transparency)

-TIFF (with & without transparency)

 

-Color Decal

-Cookie Cut Decal

-Rotoscope

 

-OpenGL3 (Anistropic Filter on and off, "Scale always to power of two" on and off)

-OpenGL

 

In all cases, the image raytraces correctly (including transparency/alpha) but realtime rendering either causes the patch to disappear entirely or display video memory garbage as per the attached screenshot. The issue didn't occur in previous (numbered) versions.

image_corruption.jpg

Share this post


Link to post
Share on other sites

Does anyone know if either of the two users mentioned above made an A:M report of this? I don't see it on the v18 bug list.

Share this post


Link to post
Share on other sites
Guest jimd13

this has been going on for a long time on my mac

and i did issue a report

 

and the problem will also show up if you use version 13 which i have on a disk

and i have 18

 

a work around is this

 

place the image you want to rotoscope or decal into the object window

if it is all messed up use the Q key and do a quick render (even if there is no model yet)

keep hitting the Q key and quick render until the Roto clears itself eventually it will

 

you might have to this again and again as you move from window to window

but it does work painfully!

 

 

j

Share this post


Link to post
Share on other sites
Guest jimd13

this has been going on for a long time on my mac

and i did issue a report

 

and the problem will also show up if you use version 13 which i have on a disk

and i have 18

 

a work around is this

 

place the image you want to rotoscope or decal into the object window

if it is all messed up use the Q key and do a quick render (even if there is no model yet)

keep hitting the Q key and quick render until the Roto clears itself eventually it will

 

you might have to this again and again as you move from window to window

but it does work painfully!

 

 

j

Share this post


Link to post
Share on other sites

jimd, do you recall the issue number?

Share this post


Link to post
Share on other sites

yes, this happens on mine too - I thought I was going nuts ! Please fix !! Can we incorporate some type of plugins etc. that will allow the use of CUDA / Open CL on Nvidia pro cards ( I have a Quadro FX 4800 ), GPU accelerated rendering would also be sweet too !! At the moment it feels like my pro graphics card is sitting there being wasted on AM - AM is too good an app to have that sort of shot comings I tells ya ! The windows people also have the same issues - I was going to install windows via boot camp to get some work done but now I see its a problem overall. I find toggling between OpenGL and Open GL3 seems to fix it sometimes, or also the toggling Anistropic Filter on and off, "Scale always to power of two" on and of etc. " refreshes " the bitmaps seriously cant be used in production like this, we have tinker with it every time we want to do some work, its not a classic Harley I tells ya !

Share this post


Link to post
Share on other sites

Am 18p on Win 7 running on Mac Pro 3,1 through bootcamp with Nvidia Quadro FX4800 working perfect wit rotoscope and texture rendering

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...