Jump to content
Hash, Inc. Forums
Sign in to follow this  
TheToadStool

removing geometry from a hair emitter

Recommended Posts

Hi this is probably a dumb question, but how do I make the geometry of a hair emitter render as invisible while the hair still shows through? I thought maybe the transparency of the geometry could be set to 100% and that wouldn't affect the hair emitter. Upon a multi-pass rendering, the hair disappears. I feel like there is a simple answer to this... This model was made before I discovered the treez plug-in, by the way...

 

 

Adam

Screen Shot 2015-08-17 at 7.34.56 PM.png

Share this post


Link to post
Share on other sites

I just tried a quick test and was able to do it.

 

 

My first guess is that you have more than one Group that your emitter patches are assigned to and one of them is making the emitter not transparent.

 

Sample PRJ: TransparentEmitterTest.prj

transparentemitter.JPG

Share this post


Link to post
Share on other sites

Try... set the geometry's group to 100% transparent... and the emitters properties to zero. Zero is the default so you will need to enter it in yourself so A:M knows it has been set... or set it to 1%...

Share this post


Link to post
Share on other sites

Thank you all so much, by the way. I've been having different problems with this, but it may be by my own doing. I was just rendering a model in multi-pass and progressively the hair would disappear. I think it's fixed now.

 

 

thanks again,

 

 

Adam

Share this post


Link to post
Share on other sites

Another thing to test, there is the 'accurate hair transparency' ON/OFF in the hair properties.

temp2.jpg

Share this post


Link to post
Share on other sites

I thought maybe the transparency of the geometry could be set to 100% and that wouldn't affect the hair emitter.

 

Ah yes. In some versions of A:M that works (as it should), in others it doesn't. In some versions there is a magic combo of settings for the emitter, and in others there isn't. I've stopped trying to figure out what/how hair works in each version. It changes sometimes from version to version (in my experience).

 

However, what I have done to make the geometry transparent, and leaving just the hair - is to apply a tga image (included in zip file), with an empty (all black) alpha channel to the group of patches that has hair. That is, rt click, on group/add image/choose invisible cookiecut image and change the type to cookie cut. Seems to works in all versions (with and without Multipass rendering)

invisiblescalphairpatches.jpg

invisiblecookiecutdecal.zip

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...