Jump to content
Hash, Inc. Forums
Sign in to follow this  
higginsdj

A:M Composite Issues

Recommended Posts

I have been trying to follow the tutorials (but without images it's a little difficult). In any case, I am finding that if I tweak a mix value low in the tree, it doesn't reflect in the real time render until I have tweaked and reset every other mix node in the tree above it.

 

Edit: I would have to say it is porked..... I change values, save the project then re-open the project only to be presented with values that do not represent what I had saved and one node no longer behaving at all (ie set itself to -ve values and will not change back)

 

Cheers

Share this post


Link to post
Share on other sites

It's probably one of the least tested features of A:M, so... maybe? I haven't noticed such a problem yet.

 

Try stepping forward and back a frame to force it to think everything through.

Share this post


Link to post
Share on other sites

A good indicator is that in v 17g (32bit and 64bit) I can't keyframe any change in composite (in fact all the animation controls are greyed out) but I can in version 16. So something is broken in 17.

 

Edit: The other problem - with changes not reflected is that in the first frame the interpolation method is spline. Set to Linear and it works correctly - not in v17 of course since it won't keyframe in the interface!

 

Edit 2: But I still have a problem with one of the nodes - neither input in the bottom Mix node - both refusing to save it's value - they keep reverting to 100% after save and reloading the project.

 

Cheers

Share this post


Link to post
Share on other sites

I just tried a simple test in v17g using the Tint post effect and I was able to keyframe a change in the tint color.

 

Can you make a simple test case that shows your situation and post it?

Share this post


Link to post
Share on other sites

I wasn't able to keyframe in v16 until I RMB'd on the "Input Percent" and chose "Time Based". That option seems to be missing in v17.

 

In v16 the input values behaved very oddly when I tried to type in numbers. I might type in 100 and get 50. If I type in 50 I might get -50.

 

Something is definitely not working right, at least with this Mix effect. The Tint effect I tried seemed to work fine.

 

We need to find a good way to describe this problem and make an AMReport.

Share this post


Link to post
Share on other sites

Reference Thread: http://www.hash.com/forums/index.php?showtopic=44599

 

Affecting v 17g (32 & 64bit) in Windows 7 Home 64bit

 

 

1. Mix Affect will not keyframe. I wasn't able to keyframe in v16 until I RMB'd on the "Input Percent" and chose "Time Based". That option seems to be missing in v17

 

2. Mix affect, lowest node in the tree, will not hold it's values when saved. (I suspect on first save it throws the values up a level and saves them there)

 

3. Mix affect will not affect frame 0 unless spline interpolation is set to Linear

 

4. Composite does not appear to work the way it was described in this tutorial thread: http://www.hash.com/forums/index.php?showtopic=15282, particularly Post 23 - Breaking out shadows - BUT that could just be my lack of understanding!

 

Cheers

Share this post


Link to post
Share on other sites

You gotta make the report at hash.com/reports and you may need to get a username and password from Jason if you haven't done AMreports before.

 

I would just make the report about the Mix post effect

 

 

#4 is a different thing entirely

Share this post


Link to post
Share on other sites

Yep - lodged. I tried to lodge a second report with file but I keep getting "Application Error #401"!

 

Edit: Seems that the creation of the report worked each time - so now I have duplicates! (looks like it was the upload that failed...)

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...