Jump to content
Hash, Inc. Forums
Sign in to follow this  
rekh

Front Project w/shadows

Recommended Posts

Hello,

 

Will helped/pointed me in the right direction to get shadows on a rotoscope image. Grabbed an image from the net, slapped my giraffe on it ... I did a search on the forum, and found a great pic of the settings that robcat2075 added to the forum....

 

How do I get strong shadows in my images. I played with various settings, and the shadows actually got worse. Is it a ground thing, or is a light thing?

 

confused.

post-9708-1347344192_thumb.jpg

Share this post


Link to post
Share on other sites

If by 'strong shadows' you mean a crisper outline if you lower the width setting of the Light the shadow should appear harder.

 

Klieg lights are often used for softer shadows (especially for raytracing) so you might change the Light type to Bulb or Sun.

 

A lighting expert will be along shortly to shine the light on us. :)

Share this post


Link to post
Share on other sites

The way a ray-traced light (Sun lights are always ray-traced) shadow fades out at the top is a special case when "rays cast" is set to 1 and the "width" is set to a non-zero value.

 

For an absolutely sharp shadow with no fade set width to 0

 

For fuzzy shadows with no fade set "rays cast" to greater than 1 and "Width" to some suitable large number.

Share this post


Link to post
Share on other sites
How do I get strong shadows in my images. I played with various settings, and the shadows actually got worse. Is it a ground thing, or is a light thing?

 

Make your ground plane: Front projected & Flat shaded

 

Start with 1 light that has shadows, a default width Klieg type with z buffered shadows., use default softness of shadow, or tweak to taste, tweak darkness of shadow. Add other lights, if you must, but you will have to retweak.

 

For this image: I believe I had chor/global ambiance Type = global Color = white, Ambiance intensity = 50-75-100?%, with 1 white Klieg probably 50-100%, shadow softness = 6.25%? darkness = 80%, color = black. Rotoscope image is all white (could be any image). I also used jenpy's fakeaocpu post effect for more darkening of "creases" on model.

 

EDIT: If you use ray trace shadows (with any kind of light), then the ground should NOT be Flat shaded, or else the shadows won't show. The shadows won't be as dark either.

3testraggy0.png

Edited by NancyGormezano

Share this post


Link to post
Share on other sites

Can't wait to get home from work and experiment.

 

You guys are awesome. Thanks for your patience with all of the questions and stuff.

 

Thanks, guys.

Share this post


Link to post
Share on other sites
beautiful image, rekh!

 

Thanks, John.

 

I'm pretty sure the background image is from the Samurai Jack series; or at least from that artist. And naturally the giraffe is my attempt at the tutorial. Used a different model sheet ... but followed the instructions as presented in TAOAM.

 

Thanks for the encouragement.

Share this post


Link to post
Share on other sites

* Update*

 

 

Time to finish the manual and stop jumping off the path.

 

 

Thanks again, people :)

 

 

Background pics are images found via links from the AM forums.

post-9708-1347432415_thumb.jpg

post-9708-1347432436_thumb.jpg

Share this post


Link to post
Share on other sites

Excellent example of adding models to pre-rendered backgrounds.

The front projection approach can be such a time saver in movie making.

 

Most importantly.... very nice results! :)

Share this post


Link to post
Share on other sites
Excellent example of adding models to pre-rendered backgrounds.

The front projection approach can be such a time saver in movie making.

 

Most importantly.... very nice results! :)

 

 

Thanks, Rodney!

 

:)

Share this post


Link to post
Share on other sites

I am having some trouble trying to get this working. When I make the ground not be flat shaded, it receives shadows fine (from a key light and a sun), but the color of the projection is off. When I make the ground be flat shaded, it does not receive shadows, even though "receive shadows" is enabled in its properties. Any hints? Thanks!

 

-Vance

sample2.jpgsample1.jpg

Share this post


Link to post
Share on other sites

Try this...

 

leave flat shaded off and set the "falloff" parameter of your shadow catcher plane to zero

 

I'm just going by memory here so come back if that doesn't work.

Share this post


Link to post
Share on other sites

Thanks, Rob! I actually figured it out. I had forgotten that flat-shaded surfaces don't receive ray-traced shadows. I had to change my sun to a klieg light and set it up for z-buffer shadows.

 

-Vance

 

Share this post


Link to post
Share on other sites

Nice work... ALSO......If you render the image out as an exr or a different method where you can get your shadow in a separate layer,

then you can use an image editor to move and manipulate the shadow/ layers as you need.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...