Jump to content
Hash, Inc. Forums

Archived

This topic is now archived and is closed to further replies.

rusty

Questions on shadows only

Recommended Posts

Hi!

 

I've never used shadows only but now it can really help me! So, I researched it, did what I thought I needed to do but I'm not getting it to work.

 

Settings Tried:

Render to TGA and then to .mov

Buffers:

Alpha=on and tried off

Shadows on

Render Options:

Quality Final

Shadows on then tried off

Everything else off

 

Nothing in Alpha buffer or RGB channels

I opened the TGA in PhotoShop CS3 and the .mov in After Effects 6.5.

I'm using AM V14c

 

Am I missing something?

 

Thanks,

Rusty

Share this post


Link to post
Share on other sites

Hi Rusty- Are you setting the 'shadows only' option on your object itself?

tempry.jpg

Share this post


Link to post
Share on other sites

The shadows-only workflow has changed a little bit since v14, i forget exactly what, but it was available in v14 somehow.

Share this post


Link to post
Share on other sites

Hi Rusty...

 

Try Jpeg and PNG format. Alpha seems to have some querks.

 

Use the EXR output also because it has a nice shadow buffer.

 

I did several things here really quick... You need to also set the "front projection" to on and mess around with it.

 

Ground_shadow_only0.jpg Shadows_only_here0.jpg

 

Shadows_meltycharacter_only0.jpg Shadows_melty0.jpg

 

William

Share this post


Link to post
Share on other sites

If you don't want to see your character, set it to "flat shaded" and front projection. To get just the ground shadow, without the ground.......set the ground to both

"front projection" and "receive shadows only" to ON Use PNG and see if that gets your layered image. Oh and make sure the shadow buffer and alpha buffers ar set to ON.

 

William

Share this post


Link to post
Share on other sites
Hi Rusty- Are you setting the 'shadows only' option on your object itself?

 

I wasn't!! Got all excited but, darn, it still didn't work.

Share this post


Link to post
Share on other sites
Hi Rusty...

 

Try Jpeg and PNG format. Alpha seems to have some querks.

 

Use the EXR output also because it has a nice shadow buffer.

 

I did several things here really quick... You need to also set the "front projection" to on and mess around with it.

 

Ground_shadow_only0.jpg Shadows_only_here0.jpg

 

Shadows_meltycharacter_only0.jpg Shadows_melty0.jpg

 

William

 

Hm... I only have one model in the chor and I want the shadows it's casting on itself. A problem? I'll turn front projection on anyway if I can.

 

Thanks for all the effort!!

 

Rusty

Share this post


Link to post
Share on other sites
If you don't want to see your character, set it to "flat shaded" and front projection. To get just the ground shadow, without the ground.......set the ground to both

"front projection" and "receive shadows only" to ON Use PNG and see if that gets your layered image. Oh and make sure the shadow buffer and alpha buffers ar set to ON.

 

William

 

So, based on the real intent of the feature, LOL, I have placed another copy of the model in the chor to receive the shadows from the original model. No luck yet but I don't know where the front projection is supposed to go, (using a normal scenario) it would seem like it would go on the ground (in my case the copy of the model I want to receive the shadows). Anyway toying with all the variations on options, settings and output format (btw jpg can't work for this as jpg's have no alpha channel).

 

Rusty

Share this post


Link to post
Share on other sites

GOT IT!! HOORAY!!!

Share this post


Link to post
Share on other sites

Another angel gets its wings every time someone figures out a feature in A:M

Share this post


Link to post
Share on other sites

ACTUALLY.....you can overlay a jpeg shadow using Multiply mode in PS or AE but I agree that it isn't ideal.. I wish that at some point an easier method of separating shadows in rendering could be done. It would require a layered render option that would give several files for each frame.

 

AS I mentioned before, the EXR output does this currently, but it isn't a straight forward process either.

Share this post


Link to post
Share on other sites
ACTUALLY.....you can overlay a jpeg shadow using Multiply mode in PS or AE but I agree that it isn't ideal.. I wish that at some point an easier method of separating shadows in rendering could be done. It would require a layered render option that would give several files for each frame.

 

AS I mentioned before, the EXR output does this currently, but it isn't a straight forward process either.

 

This option is available from v16 on without EXR.

You just have to set your format to TGA. After that, set "LightBuffers" to on and any additional buffer you want to and there will appear two new options called "Save Buffers" and "Save Lightbuffers" which should be set to "on".

 

When you render now, A:M will save these buffers out as seperate files with a name like "xyz_ShadowBuffer", etc.

You need to use Multipass to get these buffers out.

 

In v17 there is a bug in this... I dont know if it has been around for longer so. I will create a bug report on it.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites

Cool Fuchur....

 

That's great to know. I'll have to check that out.

 

Thanks for posting.

Share this post


Link to post
Share on other sites

×