Jump to content
Hash, Inc. Forums
Sign in to follow this  
Roger

Its a pitch exercise

Recommended Posts

I'm working on this exercise today, and it is just brutal trying to get this character into the proper pose. I must have spent a good 20 minutes just getting the initial pose down. Is this something that gets easier the more familiar you are with the character? I'm wondering if there is something I am doing that is making it more difficult than it needs to be.

Share this post


Link to post
Share on other sites
I'm wondering if there is something I am doing that is making it more difficult than it needs to be.

Yes.

You forgot that this is fun!

Share this post


Link to post
Share on other sites

And always set the auto balance sliders in an AM2001 character to 0

Share this post


Link to post
Share on other sites

ok, something really wierd happened - my pitch was looking fine from frame 0 through 13, then when I went to frame 18 and started the release, I got that looking good, but when I went back to frame 0 to step through the animation, its all screwed up - instead of leaning forward to throw the ball, the knight looks like he is hopping in the air. Did I accidentally set a key somehow? How do I go about figuring out where I screwed this up? I am pretty sure I was not on frame zero when I started making the changes, but on frame 18 instead.

Share this post


Link to post
Share on other sites

Well I've deleted all the keys except for the ones at frame zero, yet somehow I've still got undesired motion. I went ahead and deleted all the keyframes on the timeline, but he is still moving his right arm and right leg from frame 1 to 13. Is it possible to make a keyframe invisible accidentally, but think you've deleted it?

I guess I can go back to my previous save, I'm glad I saved the initial pose.

Share this post


Link to post
Share on other sites

Hard to tell from just a verbal description.

 

Although it isn't essential, have you watched my video on keyframing basics?

Share this post


Link to post
Share on other sites
Hard to tell from just a verbal description.

 

Although it isn't essential, have you watched my video on keyframing basics?

 

I've watched several of your tutorials, which are consistently good. I'm not sure I have watched that one yet, so I'll be sure to go back over it.

I'd render out the animation or do a screen cap so you could see the timeline along with the animation playing back at the same time, but I already

deleted it.

 

I'll watch the tutorial and if I come across the same problem, then I'll do a screengrab so I can show you whats going on. It is pretty bizarre.

Share this post


Link to post
Share on other sites

Ok, so I've watched your video on keyframing basics - just so I under stand, do I want to create the start pose, then force keyframes for all filtered channels for only the bones I will be moving so that I don't get unwanted movement? If all the bones will be moving at some point, would you force keyframes for all filtered channels on all the bones that make up the body?

 

You are basically forcing a keyframe for the bones that are moving when transitioning to the next pose, if I am following. Again, if you are doing a full body movement like the pitch exercise, I would select all the bones (arms, hips, legs, feet) and force keyframes, correct?

Share this post


Link to post
Share on other sites

Ok - I made a mistake, should be using only filtered channels that pre-exist.

 

I am in skeletal mode, trying to force keys for all the bones I anticipate having to animate.

 

I am trying to do a rectangle select around the entire model to select all the bones. I can't seem to do that, though.

All I seem to be able to do is select one bone at a time. I must be doing something wrong but am not sure what.

Share this post


Link to post
Share on other sites

Simple one-bone example case:

 

Why_You_Need_to_Force_A_KeyFrame.mov

 

Ok, so I've watched your video on keyframing basics - just so I under stand, do I want to create the start pose,

 

good so far

 

 

 

then force keyframes for all filtered channels for only the bones I will be moving so that I don't get unwanted movement?

 

Remember, for this step you are in Key Bone mode (we need more icons, Rodney!) and have manually selected all the bones you want to key.

 

We do this so

 

-we don't force keys on bones you'd never want to key ever, like hidden rig bones

-we do force complete keys on bones that , for example, may have been translated but not rotated yet in the process of making that first pose. We want to lock down both of those aspects of the bone before we move on.

 

 

If all the bones will be moving at some point, would you force keyframes for all filtered channels on all the bones that make up the body?
There are many hidden/rig/fan bones you do not want to force keys on.

 

You are basically forcing a keyframe for the bones that are moving when transitioning to the next pose, if I am following.

 

You are forcing a keyframe when you manually move a bone, but if you only translated it or only rotated it then it wont' have both translation and rotation keys created. You need both to make sure interpolation between the previous pose and the next pose isn't contaminating this current pose.

 

 

Again, if you are doing a full body movement like the pitch exercise, I would select all the bones (arms, hips, legs, feet) and force keyframes, correct?

 

After you made that first pose and then forced keyframes>"In all filtered Channels" on all the desired bones, on all subsequent poses you can turn on the "Whole model" filter, select any one bone and Force keyframe>"Only in filtered channels that pre-exist" and all the bones that were keyed in the first pose will get complete keys again, even if you hadn't needed to move them for your new pose and it does it without creating keys on hidden/rig/fan bones (since they have no channels in existence yet). This nuance is something the one-bone case can not show.

Share this post


Link to post
Share on other sites
Ok - I made a mistake, should be using only filtered channels that pre-exist.

 

I am in skeletal mode, trying to force keys for all the bones I anticipate having to animate.

 

I am trying to do a rectangle select around the entire model to select all the bones. I can't seem to do that, though.

All I seem to be able to do is select one bone at a time. I must be doing something wrong but am not sure what.

 

I'm pretty sure in that video I never tried dragging a rectangle around anything in the Chor. Did i do that? That won't work.

 

I hold down the shift key while I select the bones.

Share this post


Link to post
Share on other sites
Ok - I made a mistake, should be using only filtered channels that pre-exist.

 

I am in skeletal mode, trying to force keys for all the bones I anticipate having to animate.

 

I am trying to do a rectangle select around the entire model to select all the bones. I can't seem to do that, though.

All I seem to be able to do is select one bone at a time. I must be doing something wrong but am not sure what.

 

I'm pretty sure in that video I never tried dragging a rectangle around anything in the Chor. Did i do that? That won't work.

 

I hold down the shift key while I select the bones.

 

No, you didn't but since rectangle select works for things in other areas of AM I thought it would work for this.

I have tried shift select but can't seem to select multiple bones. I am sure I'm doing something wrong but can't quite figure out what.

Share this post


Link to post
Share on other sites

I'd have to see you do it. CTRL also works.

Share this post


Link to post
Share on other sites

Well I think I figured out a way to select all bones instead of just one - shift-click the root bone and that seems to do it. Seems like you should be able to shift-click or ctrl-click one bone, then keep going to get the rest. Maybe I'll have to make a screen cap or something.

Share this post


Link to post
Share on other sites
Seems like you should be able to shift-click or ctrl-click one bone, then keep going to get the rest.

 

I would need to see this not work.

 

I'll note that the directions in "It's a Pitch" work as written. You're doing something.

Share this post


Link to post
Share on other sites

Well, here is the 18 frames I've got so far, everything was fine until I started doing the poses for frame 18, then things started screwing up again.

At the start, I hit the single bone button, made sure all the bones were selected, and then forced a keyframe for all existing channels.

Then at frame 10, I hit the full body icon, and forced a keyframe for all existing channels. I then posed the char. Same thing for frame 13. Same for frame 18.

However, when I started to scrub through the animation, that's when I noticed that things were staying in the spots that they should be, which you can see from this flash video. I had to close and reopen AM, because the screen cap program somehow interfered with the video. I have AM open now, but can't see any keyframe data in the PWS or channel info in the timeline.

 

I suppose in order for you to figure out whats going on, I would probably have to record myself at each step, and not just the end result.

Share this post


Link to post
Share on other sites

Doh! Looks like I can't upload flash files, so I will have to redo this. Downloading camtasia now. BTW, any recommendations for screencap software if I don't have $299 to spend and would like to use camtasia (or something like it) past the 30 day trial period?

Share this post


Link to post
Share on other sites
Doh! Looks like I can't upload flash files, so I will have to redo this. Downloading camtasia now. BTW, any recommendations for screencap software if I don't have $299 to spend and would like to use camtasia (or something like it) past the 30 day trial period?

 

You can upload anything in a zip.

Share this post


Link to post
Share on other sites
At the start, I hit the single bone button, made sure all the bones were selected, and then forced a keyframe for all existing channels.

 

There's your problem. That's not what you do for the first key.

Share this post


Link to post
Share on other sites

Watch this and make sure you are selecting bones exactly like I am selecting bones.

 

Multiple_Selecting_Bones.mov

 

 

Update: Note that in the video, the "Key Bone" filter is ON, not the "Key Model" filter.

Share this post


Link to post
Share on other sites

Well, here is my vid.

 

Ok, I think I see what you're saying - since there are no existing channels (since it is frame zero) then do you do all filtered channels? Or just not force anything on frame zero? Maybe I need to watch the tutorial again and take notes this time.

AM_pitch.zip

Share this post


Link to post
Share on other sites

Ok - after watching you do it again, I think that is what I did, because all the bones were highlighted yellow when I did it on my end. I think the only thing I did wrong was use the wrong option in the dialog when forcing keyframes. I will give it another go and see if it works this time.

Share this post


Link to post
Share on other sites

For a screencapture-tool, have a look in my signature "How to make a video tutorial".

It is a little tutorial that provides you with a quite easy and free workflow to do that.

 

See you

*Fuchur*

Share this post


Link to post
Share on other sites
Well, here is my vid.

 

that video doesn't show you doing any of the selecting process that you're having trouble with.

Share this post


Link to post
Share on other sites

Ok - here is a new post of me trying to select bones. I am holding down the shift key as I'm doing it, about halfway through the video I switch to ctrl-clicking to select the bones.

I only seem to be able to click on one at a time, and some of the bones I can't select at all. I am in skeletal mode in the choreography and not an action, I'm still not sure what I'm doing wrong.

AM_screencap.mp4

Share this post


Link to post
Share on other sites
Ok - here is a new post of me trying to select bones. I am holding down the shift key as I'm doing it, about halfway through the video I switch to ctrl-clicking to select the bones.

I only seem to be able to click on one at a time, and some of the bones I can't select at all. I am in skeletal mode in the choreography and not an action, I'm still not sure what I'm doing wrong.

 

 

The first problem i see is that you are trying to select bones that appear within the sphere of a rotate manipulator. When the rotate manip (or any other manipulator) is on, A:M is waiting for you to do something with that manipulator and will prevent you from accidentally choosing other bones while you are moving the manipulator.

 

You can go on to shift select another bone you want outside the manipulator which will turn it off and give you access to bones it obscured

 

or

 

you can turn the manipulator off by hitting R

 

or

 

on bones that present the rotate manip automatically upon selection (R won't turn it off) you can manually invoke the Scale or traNslate manipulators which appear smaller on the sceen and may not obscure the bones you want

 

or

 

you can zoom in so that the rotate manipulator is smaller in proportion to the character and no longer obscures the other bones.

 

or

 

if the bones you want are already listed in your chor, you can shift select them there.

Share this post


Link to post
Share on other sites
Ok - here is a new post of me trying to select bones. I am holding down the shift key as I'm doing it, about halfway through the video I switch to ctrl-clicking to select the bones.

I only seem to be able to click on one at a time, and some of the bones I can't select at all. I am in skeletal mode in the choreography and not an action, I'm still not sure what I'm doing wrong.

 

 

The first problem i see is that you are trying to select bones that appear within the sphere of a rotate manipulator. When the rotate manip (or any other manipulator) is on, A:M is waiting for you to do something with that manipulator and will prevent you from accidentally choosing other bones while you are moving the manipulator.

 

You can go on to shift select another bone you want outside the manipulator which will turn it off and give you access to bones it obscured

 

or

 

you can turn the manipulator off by hitting R

 

or

 

on bones that present the rotate manip automatically upon selection (R won't turn it off) you can manually invoke the Scale or traNslate manipulators which appear smaller on the sceen and may not obscure the bones you want

 

or

 

you can zoom in so that the rotate manipulator is smaller in proportion to the character and no longer obscures the other bones.

 

or

 

if the bones you want are already listed in your chor, you can shift select them there.

 

OK, this is helpful. It may just be easiset for me to select them from the list in the project workspace.

Share this post


Link to post
Share on other sites

Ok, after doing this and then watching the bones pop up in the PWS when selected, it makes more sense.

I'm going to see if I can complete the pitch exercise and see how it looks.

Share this post


Link to post
Share on other sites

And remember to turn off the auto balance stuff in Knight.

Share this post


Link to post
Share on other sites
And remember to turn off the auto balance stuff in Knight.

 

:) Yes, I've already made sure to turn off the auto-balance stuff. Out of curiousity, in what situations would you want this turned on?

Share this post


Link to post
Share on other sites
Out of curiousity, in what situations would you want this turned on?

 

None have ever been found. Not in this century, nor in the last. Not in this universe nor any other.

Share this post


Link to post
Share on other sites
Out of curiousity, in what situations would you want this turned on?

 

None have ever been found. Not in this century, nor in the last. Not in this universe nor any other.

 

:D

 

Gotta wonder why it is even in there, then.

 

Anyway, I completed the exercise. Its not perfect, but doesn't look too bad after having been rendered.

itsapitch.zip

Share this post


Link to post
Share on other sites
Gotta wonder why it is even in there, then.

 

You can thank Rafael Anzovin for that one.

 

 

 

Anyway, I completed the exercise. Its not perfect, but doesn't look too bad after having been rendered.

 

So... mysteries solved?

 

 

Why is that clip a minute long? You didn't really render a whole minute did you?

Share this post


Link to post
Share on other sites

Yes, unfortunately I did render out a whole minute. I meant to render only 1 second, I must have placed the 1 in the wrong spot accidentally. But, I'm happy that I was able to successfully complete the exercise. At least I know what I was doing wrong now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...