Jump to content
Hash, Inc. Forums

Trouble getting rig mirrored.


Recommended Posts

I'm installing the 2008 rig in a model and have it all weighted and ready. However, when I actually mirror it, none of the relationships/constraints seem to be coming along for the ride. IK legs, hand controls, nothing. I tried using the "MirrorConstraints" plug as well, but that just messes with it. I've followed the instructional PDF included with the 2008 rig.

Thanks!

Animation_MasterScreenSnapz013.jpg

(I moved the foot controller in the picture to show that the leg's not following it, it wasn't there on its own.)

Link to post
Share on other sites

Are you sure the constraints aren't working? Is the mirrored side now weighted? It could be that the CP's aren't assigned.

 

It would be a lot easier if I could look at the actual model. You can delete the geometry and just post the rig...that way I can tell if the rig itself is working properly. If that is the case, then it is the weighting.

Link to post
Share on other sites

Some how the relationships on the left side got corrupted, they are somehow constrained to your armor bones.

 

Open both your model and the 2008 rig installer in the same project. Drag and drop the relationship folder from the 2008 rig installer to your models name in the PWS. That will fix the relationships. You will need to follow the directions again for exporting from the action. Make sure all poses are turned OFF as the instruction say, including your dynamic pose setup, in the models user properties, before creating the action and exporting.

 

If that doesn't work, you can send me the model and I'll fix it for you.

Link to post
Share on other sites

Yessir, I'm not sure how it was done, but the constraints were messed up. Take this model, delete the bones, name it something like "fix.mdl" and save it. Then, delete the constraints in your model and import "fix.mdl" into your model.

 

Hope that helps.

 

 

 

-----------------------

EDIT

-----------------------

 

Mark knows best with the 2008 Rig, so go with his suggestions.

Orc_Warrior_rig_update.zip

Link to post
Share on other sites

Alright, looking in to it now. Thank you both a ton! I'll let you know what I come up with.

 

edit: Fantastic! Copying the relationships back over from the installer did the trick. Thanks again!!

Link to post
Share on other sites
I would not use the mirror constraints for duplicating the dynamic constraints. The mirror constraints plugin will screw up the 2008 rig relationships.

ha ha, yeah, found that out first hand.

Link to post
Share on other sites

There are work arounds to be able to use the mirror constraints plugin. You would need to delete all the 2008 relationships, except for your dynamics pose, then use the plugin. Then you would just need to drag and drop the relationship folder, from the 2008 rig installer, back onto your model, just like you did to fix it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...