Jump to content
Hash, Inc. Forums
bubba

Moving Bones to create Action

Recommended Posts

I have finished the "rough draft" of my Warhawk BattleMech. This is the upper body portion.

 

WarHawkUpperBody0.jpg

 

I put the following bones in

 

Screen_shot_2011_02_14_at_2.24.50_PM.jpg

 

 

Here is the PWS showing the relationship of these bones

 

Screen_shot_2011_02_14_at_2.22.35_PM.jpg

 

But when I try to move the lower arm bone (we would call it a forearm bone) all I can do is rotate it - but I want to translate it to move back and forth - either extending or retracting the "hand".

 

Here is the lower half

 

Screen_shot_2011_02_14_at_2.29.31_PM.jpg

 

It will require a "chicken walk"

 

I have looked at the Technical Reference, ToAM manual, the 2000 A:M manual, the "lets take a walk" tutorial, David Rogers book, ...

 

Thanks so much for all the past help.

Share this post


Link to post
Share on other sites

Your "lower Arm bone" is "Attached to Parent" (probably desireable) so normally it can't move from where it is attached.

 

If your arm has a an IK ("Inverse Kinematics") rig like you did for your legs (?) then you would be able to lead the arm around by just moving one target.

 

 

Absent that, you need to pose the bones above the lower arm to get it to the position you want. (FK or "Forward Kinematics")

Share this post


Link to post
Share on other sites

Also, I presume you are trying to animate your character in a chor or action, not in the model window.

Share this post


Link to post
Share on other sites

Yes I tried working in both the Action and Choreography window.

 

Yes, the arms should have a IK rig (lower arm) attached to the upper arm.

 

The big bone in the center of the model I call the "body bone" and restricted it to only turn in the horizontal. Since it is the parent of all the arm bones (but only the two arm bones are attached), can this restriction be flowing down to the arms?

Share this post


Link to post
Share on other sites

I'd need to see a screencam of what you are doing, the written description unclear.

Share this post


Link to post
Share on other sites

But I can't see from that what you're trying to do while you're in the chor window.

 

If you want to send it to me I'll look at it.

 

Do Project>Embedd All and save the Project under a new name and send it to me at

 

theguy (at) brilliantisland.com

Share this post


Link to post
Share on other sites

I can't recreate the problem of being able to only move that bone on one axis. I can turn it anywhere. I'd have to see a screencam of you trying to do it to see what you are doing differently

 

here's how i do it and how I think you should proceed with your model

 

 

Adding_IK_Leg.mov

Share this post


Link to post
Share on other sites

amazing tutorial Robert .. thank you

Share this post


Link to post
Share on other sites

Yes Robert I agree amazing tutorial. Thank you also.

 

You are correct I was trying to translate the "hand". And I was not using the rotate manipulator rings, I was just trying to grab the hand and push/pull it. The only way it would go is in a horizontal circle.

 

For the leg you suggest a null. What about the manipulator properties - rotate or translate? Select rotate and restrict to just the x (or y?) axis?

 

Finally I tried to save the movie but failed. Would you be kind enough to send me a copy?

Share this post


Link to post
Share on other sites
Finally I tried to save the movie but failed. Would you be kind enough to send me a copy?

 

Did you try to Right Click and then Save As?

Saving from the online movie never works for me. (I seem to recall I could do that before. Must be a browser thing.)

Share this post


Link to post
Share on other sites
Finally I tried to save the movie but failed. Would you be kind enough to send me a copy?

 

Did you try to Right Click and then Save As?

Saving from the online movie never works for me. (I seem to recall I could do that before. Must be a browser thing.)

 

 

Neither is working for me today. My browser is Firefox. If I Right Click on the link is see several open selections, save links, send links; but no Save As...

 

If I right click on the link the quictime movie opens and plays. If I right click on the movie I can "Save as Quicktime Movie" but what is really saved is a script, not the actual movie. Hash must store the uploads on another server.

Share this post


Link to post
Share on other sites

Robert -

 

You mention another IK chain posting. I cannot remember it and I tried searching on IK chain but the Forums do not allow 3 or less words. Can you help again. Thanks.

Share this post


Link to post
Share on other sites

"Simplest IK Leg" is in the the screencam tuts in the link in my signature.

Share this post


Link to post
Share on other sites

I'm using Firefox on WinXP and I just saved the movie to my hard disk without any problem. Right-click on the link and choose "Save Link As". If that isn't working for you, you have something weird going on with your computer.

Share this post


Link to post
Share on other sites
You are correct I was trying to translate the "hand". And I was not using the rotate manipulator rings, I was just trying to grab the hand and push/pull it. The only way it would go is in a horizontal circle.

 

I'd have to see you doing it to know exactly why you only got a horizontal motion.

 

For the leg you suggest a null. What about the manipulator properties - rotate or translate? Select rotate and restrict to just the x (or y?) axis?

 

I think... manipulator properties only limit the manipulator possibilites, but another bone acting on the bone could still move it anywhere.

 

A target null is my simple solution that will also work for characters that need to be able to point their knees. For a robot that would never do that an Euler constraint might be an option to limit rotation on a bone.

Share this post


Link to post
Share on other sites

Apparently the movie is too large for me to e-mail.

 

Try right-click>Save Link As

Share this post


Link to post
Share on other sites

Thank you all for pointing out the "Save Link As..." I really thought this would just save the Link.

 

24MB is almost pushing the limits of Hash too.

Share this post


Link to post
Share on other sites
Robert, as you will see from the attached video, I am doing something incorrect but I do not know what.

 

IKLegChain.mov

 

Thanks.

 

That movie appear to be empty. Are you on a mac? I think that one needs to be flattened. Look for something like "make self-contained."

Share this post


Link to post
Share on other sites

Sorry about that. The original screen capture was 397MB and I thought I was shrinking it down to a manageable size. For some reason, the Hash Forums software does not like .m4v (MPEG-4) video. Lets give this new one a try.

 

I am using the 19 January release of V16. Comparing your video with my result it looks to me like "turning on POSE" does nothing.

 

Question: can't the IK constraint be done in the choreography window? Also, what about adding a target bone and leaving the foot pedestal attached to the chain?

 

My system is a MacPro 8-core machine with 20GB or RAM.

Share this post


Link to post
Share on other sites
Sorry about that. The original screen capture was 397MB and I thought I was shrinking it down to a manageable size. For some reason, the Hash Forums software does not like .m4v (MPEG-4) video. Lets give this new one a try.

 

I am using the 19 January release of V16. Comparing your video with my result it looks to me like "turning on POSE" does nothing.

 

Question: can't the IK constraint be done in the choreography window? Also, what about adding a target bone and leaving the foot pedestal attached to the chain?

 

My system is a MacPro 8-core machine with 20GB or RAM.

 

I don't see a link to a file. 397 MB would definitely be too big.

Share this post


Link to post
Share on other sites

I got it down to 10MB but it still wouldn't upload. I emailed it to you.

Share this post


Link to post
Share on other sites

10 MB may be too big for my mail box. Try putting it in a zip if the forum wont take it as an .mv4?

Share this post


Link to post
Share on other sites

OK, i was able to see that. I presume there was no sound

 

- try saving the PRJ, closing it, then re-loading and see if the constraint works. I have found some occasions where the last constraint I make doesn't get recognized until i force a save.

Share this post


Link to post
Share on other sites

No I am sorry there was no sound. Quicktime X has screen capture but not audio recording (I don't think.) Anyway I don't have a microphone either. I will try the sequence again saving the PRJ this time.

Share this post


Link to post
Share on other sites
No I am sorry there was no sound. Quicktime X has screen capture but not audio recording (I don't think.) Anyway I don't have a microphone either. I will try the sequence again saving the PRJ this time.

Qucktime X can record audio as well. When the small record window opens in Quicktime X, click on the little white triangle to the right of the central record button. This gives you a drop down menu for some settings including audio options.

Quicktime_X_Options.png

Share this post


Link to post
Share on other sites
OK, i was able to see that. I presume there was no sound

 

- try saving the PRJ, closing it, then re-loading and see if the constraint works. I have found some occasions where the last constraint I make doesn't get recognized until i force a save.

 

 

I closed/saved the project after establishing the pose relationship. Re-opened the file and drug the lower body model into the Choreography window. Still doesn't work.

Share this post


Link to post
Share on other sites
OK, i was able to see that. I presume there was no sound

 

- try saving the PRJ, closing it, then re-loading and see if the constraint works. I have found some occasions where the last constraint I make doesn't get recognized until i force a save.

 

 

I closed/saved the project after establishing the pose relationship. Re-opened the file and drug the lower body model into the Choreography window. Still doesn't work.

 

 

Send me the PRJ that you saved.

Share this post


Link to post
Share on other sites

the good news is it works fine here!

 

the bad news is, i don't know why it's not working for you.

 

Try this and see what happens:

 

IKSeemsToBeWorking2.mov

 

Also to try ....move the time slider to something other than 0:00 then move it back and see if the constraint works.

Share this post


Link to post
Share on other sites

Strange, very strange.

 

First of all, are we using the same version of A:M? Second, are there options/preferences that are unique to poses/constraints? Third, would you return the project just to see how it works on my system. Fourth, I don't know much about Community but it sounds like it might be a way for us to chart "real-time."

If this is a "bug" in the Mac version of 16 I want to nail it so that Yoda64 can make the fix as soon as he can.

Share this post


Link to post
Share on other sites

Robert -

 

I tried to finish up the two nulls but my PWS looks strange. Also, there does seem to be some action with the constraints.

 

Screen_shot_2011_02_18_at_11.29.44_AM.jpg

Share this post


Link to post
Share on other sites

I've sent your PRJ to you after a resave.

 

I'm on PC and you're on Mac so there's that possible difference. I may have a slightly later build. But you're the only mac user so far that hasn't been able to get constraints to work.

 

Install v15 and try your PRJ in that. You can have both installed. Copy the master0.lic file that is in the A:M folder over to the new install to enable it.

Share this post


Link to post
Share on other sites
Robert -

 

I tried to finish up the two nulls but my PWS looks strange. Also, there does seem to be some action with the constraints.

 

Screen_shot_2011_02_18_at_11.29.44_AM.jpg

 

The "Aim at" constraints are something you do to the upper leg bones not the lower ones.

 

Also the nulls need to be added and placed in the model window rather than in the Pose window. That may be why they are regarded as "action objects" in your version. Not that that couldn't work but it's a bit non-standard.

Share this post


Link to post
Share on other sites
I've sent your PRJ to you after a resave.

 

 

Did you send it (the PRJ) yet?

Share this post


Link to post
Share on other sites

OK, I am posting two screen capture videos - one for the version 15.0j+ and one for the 19 January version 16rc 01. I could use some more eyes on but it looks to me that there is a definite problem with constraints not working in version 16. The exact same file was used in both cases; and is the same file that RobCat2075 used in his demos.

 

v15_I_can_believe.mov

 

V16_You_will_not_believe_this.mov

 

 

In the version 15 video, would manipulator options keep the leg from moving all around the place?

Share this post


Link to post
Share on other sites

Thanks Homeslice, but if there were made with the Windows version of version 16 you won't see the problem, as evidenced by RobCat2075's postings.

Share this post


Link to post
Share on other sites

Oh OK, so it's a Mac thing. Sorry, can't help with that one. Perhaps you should change the title of this thread to something like "Mac Rigging Issue"

Share this post


Link to post
Share on other sites

For now, can you get by with v15? V16 is really just a beta right now, but it's good to find these things.

Share this post


Link to post
Share on other sites

Should I send it in to Yoda64 (you could send in your video for comparison.)

 

Version 15.0j+ has one issue with titles in the Library, which I don't use anyway. So I will see how it goes with version 15.

 

Homeslice - I downloaded your tutorials and will give them a study. Thanks.

Share this post


Link to post
Share on other sites

How (why) did this get moved to this form from the Newbees?

 

As I mentioned to someone, animation is my hobby not my profession, so I don't mind being on the "bleeding" edge of technology. Finds issues and helping to correct them gives me a sense of accomplishment.

Share this post


Link to post
Share on other sites

Maybe because it's a genuine AM report thing and not new-guy-doesn't-know-what-he's-doing :)

Share this post


Link to post
Share on other sites

I'm looking at your two videos...

 

In "v15 I can believe" the project has the title "WarhawkAlt6_TwoKeysAddedv15" and in the other vid the title is only "WarhawkAlt6_TwoKeysAdded"

 

so there's some difference between the two. What changed...

Share this post


Link to post
Share on other sites
I'm looking at your two videos...

 

In "v15 I can believe" the project has the title "WarhawkAlt6_TwoKeysAddedv15" and in the other vid the title is only "WarhawkAlt6_TwoKeysAdded"

 

so there's some difference between the two. What changed...

 

 

I simply re-named the file. It also allows me to have a PRJ file for each version.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...