Jump to content
Hash, Inc. Forums
Darkwing

The Infamous Bone Snapping thing

Recommended Posts

Yeah, sorry about the big words plastered over the vid and sorry about the file size. This vid actually points out 3 bugs in the AM version of 10.6 (this is whatever the newest RC is as well)

 

am.mov

Share this post


Link to post
Share on other sites
Yeah, sorry about the big words plastered over the vid and sorry about the file size. This vid actually points out 3 bugs in the AM version of 10.6 (this is whatever the newest RC is as well)

 

am.mov

 

yes I have the same bone snap issue version 16

but not the locked arrow button mine works fine

and yes the good old can't hit the render button thats been around for all the versions

for me 13 to 16

Share this post


Link to post
Share on other sites

Yeah, I first noticed the render to file one in V15, but I've only used V15 and 16 on the mac

Share this post


Link to post
Share on other sites

That does look odd.

 

Why didn't you change the Rotate Snap Angle setting? Just to try it.

 

 

I'm wondering if there's some User Simplification setting on Macs that is causing the dragging direction to be constrained to certain angles?

Share this post


Link to post
Share on other sites

Has no effect, still does th same thing to the same extent as before

Share this post


Link to post
Share on other sites

Update: Bone doesn't even move in action or chor mode

Share this post


Link to post
Share on other sites

When you do a right-click-drag selection box does the corner follow you cursor exactly or does it snap like that bone tip?

Share this post


Link to post
Share on other sites
When you do a right-click-drag selection box does the corner follow you cursor exactly or does it snap like that bone tip?

 

right click drag

you can drag the bass but tip snaps

iShowU_Capture.mov

Share this post


Link to post
Share on other sites

Any snap to grid, mirror-mode, etc. active?

 

*Fuchur*

Share this post


Link to post
Share on other sites
When you do a right-click-drag selection box does the corner follow you cursor exactly or does it snap like that bone tip?

 

right click drag

you can drag the bass but tip snaps

 

 

How is that a selection box?

 

Just do a selection box on your desktop. Does the corner follow your cursor exactly or does it snap like that bone tip?

Share this post


Link to post
Share on other sites
Any snap to grid, mirror-mode, etc. active?

 

*Fuchur*

 

that would be a no

and you can no longer freely grab a bone and manipulate in the cho

you need to use rotate

Share this post


Link to post
Share on other sites

Do any other Mac users have this?

 

 

Is this in an AMReport yet? What number is it?

Share this post


Link to post
Share on other sites
When you do a right-click-drag selection box does the corner follow you cursor exactly or does it snap like that bone tip?

 

I can do a normal click and drag and make a box and the corner follows the cursor smoothly and exactly

 

Any snap to grid, mirror-mode, etc. active?

 

*Fuchur*

No and no

 

 

Any snap to grid, mirror-mode, etc. active?

 

*Fuchur*

 

that would be a no

and you can no longer freely grab a bone and manipulate in the cho

you need to use rotate

 

If you saw my video, even rotate causes it to snap like that

Share this post


Link to post
Share on other sites

I can verify the bone tip not freely moving but snapping. Tired setting the snap angle to 1 - haven't tired anything smaller.

 

I cannot verify the Tools>Options issue. I can use both arrows to scroll back and forth.

 

I have had issues getting the Render-to-File button to work also. Seems intermittent.

 

Glad you submitted a bug report. Hopefully Yoda64 can solve it quickly.

 

Sorry to add a separate issue to this discussion but has anyone noticed that clicking on a navigation button (Hand, turn, magnify) causes the model in the active window to jump to a different view. Or the button won't stay selected so that you can't perform a single action?

Share this post


Link to post
Share on other sites
Do any other Mac users have this?

 

 

Is this in an AMReport yet? What number is it?

 

Yes, I just noticed this bug in the Mac version as well. (Latest v16 RC)

Share this post


Link to post
Share on other sites
Yes, I just noticed this bug in the Mac version as well. (Latest v16 RC)

 

So if you go back to the V16 you had before, what happens? Or v15?

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...