Jump to content
Hash, Inc. Forums

2008 rig Copy/Paste Mirrored problems


Recommended Posts

I'm using the v.13 2008 rig and am getting confusing results in an action when trying to copy/paste mirrored keyframes to create a walk cycle. Running latest version of A:M on Mac 10.4.11. I've tried everything I can think of, including pasting every bone singularly instead of using the bone tree or model tabs. The body control and chest control nulls create body distortions. Any idea what I'm running into and why?

Link to post
Share on other sites

odd results can happen if bones are not exactly mirrored in the model.

 

Try increasing the paste mirror tolerance, the default is quite small at .01

 

That said, some fixes are coming in the next A:M release.

Link to post
Share on other sites
odd results can happen if bones are not exactly mirrored in the model.

 

Try increasing the paste mirror tolerance, the default is quite small at .01

 

That said, some fixes are coming in the next A:M release.

 

where do I change the 'paste mirrored tolerance'?

Link to post
Share on other sites
I have no issues here. Can you post some screen grabs and/or the action file?

 

argggh - can't upload the action file!

 

attached are screen grabs of frame 1 and frame 13 - the latter being the mirror paste of the former.

 

I've tried changing the 'mirror mode' option in the 'modeling options' menu - from .05 tolerance to .15 - to no avail

frame1.jpg

frame13.jpg

Link to post
Share on other sites
What keyframe filtering keys do you have turned on when you do the copy/paste ? (eg model, branch, bone, translate, scale, rotate, other etc)

 

I believe there is a magic combo, which I'm sure someone (rob, mark) can tell you what it is

 

I've used the 'model' key - I don't know where the 'translate, scale, rotate, other etc' keys are. The choices I have are 'model, branch, bone'.

'

Link to post
Share on other sites

I tried your PRJ and I get a odd result also.

 

Wait a few days for v15h to come out. I put in an AMReport on Paste Mirror a while ago and I believe Steffen has addressed it in the next release.

 

Steffen explained to me that in rigs like TSM2 and 2008 apparently, the CPM algorithm can get confused by hidden rig bones that are in nearly same positions as control bones. Notice that bones like Chest Controller Parent are getting keyed by CPM even though those weren't keyed to begin with and shouldn't be getting a mirror treatment.

 

Wait a few days for v15h to come out. Sorry for the frustration.

 

I don't know where the 'translate, scale, rotate, other etc' keys are. The choices I have are 'model, branch, bone'.

'

 

to the left of those. hover over them and they have names.

 

BTW, have you watched my keyframing options vid inthetuts link in my sig? It covers that stuff.

Link to post
Share on other sites
I tried your PRJ and I get a odd result also.

 

Wait a few days for v15h to come out. I put in an AMReport on Paste Mirror a while ago and I believe Steffen has addressed it in the next release.

 

Steffen explained to me that in rigs like TSM2 and 2008 apparently, the CPM algorithm can get confused by hidden rig bones that are in nearly same positions as control bones. Notice that bones like Chest Controller Parent are getting keyed by CPM even though those weren't keyed to begin with and shouldn't be getting a mirror treatment.

 

Wait a few days for v15h to come out. Sorry for the frustration.

 

I don't know where the 'translate, scale, rotate, other etc' keys are. The choices I have are 'model, branch, bone'.

'

 

to the left of those. hover over them and they have names.

 

BTW, have you watched my keyframing options vid inthetuts link in my sig? It covers that stuff.

 

 

I have not watched those tuts yet - will check 'em out!

 

Thanks for all the info.

Link to post
Share on other sites
What keyframe filtering keys do you have turned on when you do the copy/paste ? (eg model, branch, bone, translate, scale, rotate, other etc)

 

I believe there is a magic combo, which I'm sure someone (rob, mark) can tell you what it is

 

I've used the 'model' key - I don't know where the 'translate, scale, rotate, other etc' keys are. The choices I have are 'model, branch, bone'.

'

 

I didn't see them on your screen capture? Weird.

 

tools/customize/commands/frame

keyframeFilters.jpg

Link to post
Share on other sites
What keyframe filtering keys do you have turned on when you do the copy/paste ? (eg model, branch, bone, translate, scale, rotate, other etc)

 

I believe there is a magic combo, which I'm sure someone (rob, mark) can tell you what it is

 

I've used the 'model' key - I don't know where the 'translate, scale, rotate, other etc' keys are. The choices I have are 'model, branch, bone'.

'

 

I didn't see them on your screen capture? Weird.

 

tools/customize/commands/frame

 

I probably got rid of them when customizing my workspace (not really knowing what they were for). I'll reboot A:M after restoring to the factory settings and see if they show up. If not, I'll add them to my toolbar. Thank you.

Link to post
Share on other sites

I've had odd results when copy/paste mirrored on the Squetch rig from time to time. In my cases, it was only the Torso/Chest Controller that did funny things. That is easy for you to fix. Just set its rotation back to 0,0,0 and adjust it manually.

Link to post
Share on other sites

This is very odd, the Thom model has this issue, but the Robby model doesn't (both posted as example models). I'll have to dig into both rigs to see if there is anything different, replacing the relationships has no affect.

Link to post
Share on other sites
Ok, I don't really know what the issue exactly was, but I re-exported the model from an action and it fixed the problem.

 

The fixed model is here.

 

Thanks for the link. I have also created a model using the body of the 2008 rig with a head created by me. I've done quite a bit of editing, poses and whatnot, on this model and would like to use it without creating a whole new model. How did you "re-export the model from an action" to fix the problem? Being able to do this would alleviate a lot of work I'd have to re-address with the fixed model from your link.

Link to post
Share on other sites

In the models user properties, turn OFF the IK legs and arms (if they're ON), turn OFF all the poses in the spine folder. Create a new action and export the model from the action (right click in the action window and choose export>model. Don't know how to do that on a Mac). Start new project and open the exported model, turn ON all the poses in the user properties you turned OFF and save.

 

Note: Make sure ALL the poses that YOU created are turned OFF or set to 0%, in the models user properties, before exporting.

Link to post
Share on other sites
In the models user properties, turn OFF the IK legs and arms (if they're ON), turn OFF all the poses in the spine folder. Create a new action and export the model from the action (right click in the action window and choose export>model. Don't know how to do that on a Mac). Start new project and open the exported model, turn ON all the poses in the user properties you turned OFF and save.

 

Note: Make sure ALL the poses that YOU created are turned OFF or set to 0%, in the models user properties, before exporting.

 

Thanks, mtpeak! I'll give it a try and see what happens.

Link to post
Share on other sites
In the models user properties, turn OFF the IK legs and arms (if they're ON), turn OFF all the poses in the spine folder. Create a new action and export the model from the action (right click in the action window and choose export>model. Don't know how to do that on a Mac). Start new project and open the exported model, turn ON all the poses in the user properties you turned OFF and save.

 

Note: Make sure ALL the poses that YOU created are turned OFF or set to 0%, in the models user properties, before exporting.

 

That solved the problem! Thank you.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...