Jump to content
Hash, Inc. Forums
Sign in to follow this  
John Bigboote

Transferring groomed hair...?

Recommended Posts

HI!

 

I have a model with 3 different types/lengths of hair on it. I have a goup called 'BANGS' that I want to do some styling to. If I try it in the model, things go very slowly and little if any effect happens with each hairbrush stroke... I have preroll off, dynamics off and all the other jazz that makes for computations.

 

BUT- If I copy the group into a NEW model and attempt to style...everything goes swimmingly well and I can get what I wanted rather quickly.

 

SO- I now need to transfer the newly styled group BACK into the original model WITH all the styling intact. A simple copy/paste seems to do what I want...the group has the hair material and all the 'guide hair' information- but it doesn't 'take' on the model (it appears and renders un-styled) even after a save/close/reopen.

 

I did a search but could not find a discussion on this... WHAT IS THE TRICK?

Share this post


Link to post
Share on other sites

OK- found my answer.

 

IT INVOLVES: Copy Paste the geometry from the model into a NEW model, THEN- delete the hair material from the original model. IN THE NEW MODEL, groom the hair as desired... it should be nice and tactile. When grooming is finished- SAVE AS a new model (BANGSgroomed.mdl) You might also want to save the hair material as a new name. BACK IN THE ORIGINAL MODEL, right click on the model name and choose IMPORT the groomed model (e.g. BANGSgroomed.mdl)

 

You should now have all the grooming info intact and working.

Share this post


Link to post
Share on other sites

Good find!

 

You might make an A:M report of the fact that you get such different responses from what should be the same hair. I bet the initial slow response discourages a lot of people who try it.

 

And if it doesn't really have to be that way...

Share this post


Link to post
Share on other sites

That's a neat solution Matt. You can also speed up real time interaction with hair by making sure that under the material's "Hair System" set the "Quality" from "Shaded" to "Wireframe". If it is still too slow then you can also change "Density Factor", found right underneath "Quality", to something less then 100%. Again all these settings applies to real time interaction and have nothing to do with final rendering ... Although Matt I'm sure you probably already knew all of this. ;)

Share this post


Link to post
Share on other sites

I found too, that when I was grooming my polar bear model, that if I hid the geometry of the areas I wasn't currently grooming, I got a much faster response. Try hiding the geometry that doesn't have the hair material applied to it in the original model. I have no idea why that might change the response time, but it might...

Share this post


Link to post
Share on other sites

Oh yeah- I'm hiding it! I make ONLY the patches visible that I want to work with...PLUS I am making the realtime settings really low. I think the problem is... I discovered that for good collision-detection to work you need the hairs to be emitted from a really dense mesh, thus more 'guide hairs' and less 'fill hairs' to crash thru bodies. The mesh I am working on is not dense at all, but there ARE some really dense (altho hidden) mesh's emitting hair in the same model- and they may be clogging-up the works.

Share this post


Link to post
Share on other sites

If you get a major slowdown while working on something try closing any other window,(choreography and action), that has that model in it, especially for objects with hair, displacement or dynamics. Of course, with hair, you can turn down density, increase culling, work with wireframes, etc to keep things fluid and you should have dynamics off while grooming.

Share this post


Link to post
Share on other sites

I forgot to mention that trick, Paul... but yes- I was doing that as well. If I have the model open in other action, pose, chor windows then A:M is trying to simulate the effect in those windows as well which slows things down. I had JUST the model open. Dynamics OFF, then once groomed, you can set your dynamic to CONSTRAINT, and adjust the amount of 'hold' or looseness your style will have.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...