Jump to content
Hash, Inc. Forums
Master chief

jet thruster effect

Recommended Posts

pretty simple i have a jet plane that has jet engines and i need an effect to show that its working

 

something like this would be nice

 

Image location

 

i know that this image is attached to a modeling guide but the guide is to the wrong part of what i want , i want the flame effect not the how to build a nozzel

Share this post


Link to post
Share on other sites

if you use the search option on the top right of forum click on more search options yo can find plenty of info usually

 

 

here is my 1.98 example

 

 

streaks.mov

 

 

streaks.zip

 

 

I turned off gravity in the chor ..made model with emitter group ... put together streak material...( particles straeks) ..selected color etc then adjust size for effect ...animated model....streak output could be controled by pose either on /off or %

 

only had a few minutes leaving for work

Share this post


Link to post
Share on other sites

One way would be to make an animated map applied to a cylinder where the jet exhaust would be. But then you're going to ask for a tut on making the animated map. ;)

 

 

Streaks are a likely solution

 

make a ring for an emitter. A ring because you want teh edges of the exhaust to look denser than the middle.

 

have it emit lots of nearly 100 % transparent streaks. High velocity. have them die off to 100% transparent in a few frames. make them 100% ambient so they look like they glow.

 

 

you can vary the spray of the jet by varying the shape of the emitter.

 

one problem with particles is that they tend to clump around exact frame times rather than be emitted randomly over the life of the effect. short streaks tend to look like pancakes are being fired out.

 

One work around is to up the PRJ to a higher fps and then render fewer frames to compensate. you'll need to render to TGAs because quicktime will be fooled into thinking you want the higher frame rate.

 

 

this was a 48fps PRJ rendered with "step" at 2 to get just 24 fps

 

jetblastD.mov

 

 

JetBlast02_48fps.zip

 

 

 

MANY more particles, shorter and more transparent would get closer to the gassy effect in the example you showed. (thanks for showing an example!) Render time will go up, of course.

Share this post


Link to post
Share on other sites

ok run into a little problem , i was tweeking the file that rob uploaded to see what effects i could get and as far as i know i set the render setting to render sprites . but when i try and render nothing happens , im noting that i have to set render sprites on every time and its not sticking so that may be it but was wondering if this might be caused by anything else

Share this post


Link to post
Share on other sites

you mean "particles" ON?

 

 

Nothing renders even if you just load the PRJ and render it without changes?

Share this post


Link to post
Share on other sites
you mean "particles" ON?

 

 

Nothing renders even if you just load the PRJ and render it without changes?

 

sequence of events

 

1 downloaded file

2 oped file

3 looked over how it was setup

4 tryed to change the color of the jets to red

5 started the renderer

6 selected i frame bout 5 seconds in and made sure draw particals / hair was on

7 rendered for 30 seconds

8 result was just the cone , no effect

 

 

noting that trying this again showed the draw particals / hair was turned off again , could this mean AM is broken and not able to render these particular items

Share this post


Link to post
Share on other sites
you mean "particles" ON?

 

 

Nothing renders even if you just load the PRJ and render it without changes?

 

sequence of events

 

1 downloaded file

2 oped file

3 looked over how it was setup

4 tryed to change the color of the jets to red

 

So you haven't tried just rendering the Project unaltered. That should have been step #1.

 

 

 

 

5 started the renderer

6 selected i frame bout 5 seconds in and made sure draw particals / hair was on

 

notice that my animation is only 3 seconds long and the particles stop at about 2.5 seconds. the emitter is keyed to 0 then.

 

I f you 're rendering something at 5 seconds out you're not going to get anything.

 

 

 

noting that trying this again showed the draw particals / hair was turned off again , could this mean AM is broken and not able to render these particular items

 

A:M is not broken. I believe V15 turns off particles after every render so projects with lots of hair don't' take forever to reappear after a render.

Share this post


Link to post
Share on other sites

Sorry to high jack

 

Can you explain how this works, "this was a 48fps PRJ rendered with "step" at 2 to get just 24 fps" I have never understood the step option and its relationship to the project frame rate.

Share this post


Link to post
Share on other sites
Sorry to high jack

 

Can you explain how this works, "this was a 48fps PRJ rendered with "step" at 2 to get just 24 fps" I have never understood the step option and its relationship to the project frame rate.

 

Technically "step" isn't about the frame rate setting in your PRJ. It's just a way of rendering fewer frames than normal.

 

step = 2 would render every other frame in your chor

 

image000.tga

image002.tga

image004.tga

image006.tga...

 

 

 

step = 3 would render every third frame in your chor

 

image000.tga

image003.tga

image006.tga

image009.tga...

 

 

I made my PRJ 48 fps instead of 24 fps because i wanted the particle emitter to emit particles more than once every 1/24th second. But I dont' really want all those frames rendered. I just wanted 24 frames per second. So I set step = 2

 

 

However, when rendering to Quicktime, the quicktime file seems to take its fps information from the project frame rate so when i render a 48 fps project with step = 2, I will get 24 frames from the 1st second of my chor but quicktime will give each one only 1/48th of a second when it plays them. this makes the action look like it's going 2x too fast.

 

i had to render to targas, and import the sequence to QT Pro and tell it to think they were intended as 24fps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...