Jump to content
Hash, Inc. Forums
Sign in to follow this  
Masna

No Library?

Recommended Posts

Hey guys,

 

I just uploaded A:M onto my new computer and for some reason my library doesn't seem to be coming up. All of the folders are in the computer, but not linked to the library. Does anyone know how to fix this?

 

Thanks,

Masna

Share this post


Link to post
Share on other sites

When you say your Library doesn't come up...

Do you mean that no Library... even an empty one... appears?

 

Seeing no Library would be an indication that you need to go to |View| Libraries on the menu and activate your Libraries. Alt 5 is the shortcut key that will turn the Libraries off and on.

 

If you see at least one Libary, empty or otherwise, we can press on and connect you to your Library.

If you don't see any Library we've got a different problem.

Share this post


Link to post
Share on other sites

Yes, I have the library window open, but it's completely blank. I also have the all of the files that should be in the library in the A:M program folder, but it would be of much greater convenience to be able to access the library from the program. Do you know how I would go about linking all the files to the program?

Share this post


Link to post
Share on other sites

I *believe* it's Tools>Options>Folders>Show folders for: Libraries, then click New and click the Browse button with the "..." on it, and browse to your libraries folder. This is on the Mac, may be different on the PC side.

 

If this isn't correct hopefully someone else will chime in.

Share this post


Link to post
Share on other sites

There are other links in the forum that walk you through the process of connecting to your Library but I have these handy so...

 

As Gerry suggests go to TOOLS on your menu and select OPTIONS (You can use the shortcut keys 'Control P' to get to the same place via your Keybooard. Try it.)

ControlP.png

Share this post


Link to post
Share on other sites

Then you need to navigate to the Folders tab.

FoldersTab.png

Share this post


Link to post
Share on other sites

In the 'Show Folders for' dropdown menu select 'Libraries' and note the locations that show in the main window.

Here you can add and delete Library folders.

To add a library click on the Folder icon

Browse to the folder that has your Libraries (via the |...| icon)

 

To Delete a Library click on the Red X.

 

While you can do it, you should avoid typing in the location manually.

If you misspell anything or miss anything your Library won't connect.

Better to Browse for it.

InsertLibrary.png

DeleteLibraries.png

Share this post


Link to post
Share on other sites

Having clicked on the |...| icon you now Browse to your Library folder.

LibraryFolder.png

Share this post


Link to post
Share on other sites

This will connect A:M to the Library folder you've selected.

Any Library file inside that folder will now be active in A:M.

 

Click the |OK| button to save your new setting.

 

Note: You must restart A:M before you'll see the change take effect.

Connected.png

Share this post


Link to post
Share on other sites

Thanks for all of the help Rodney! Unfortunately whenever I pess "..." A:M crashes. <_<

 

I'll report this bug to Hash, but I'm not sure how much they can do about it.

Share this post


Link to post
Share on other sites

Are you on Mac or PC? Anything you can tell us about your system could help. The problem with making a bug report is that your problem is not connected to a prj or file to reproduce the problem. Not that you shouldn't make a report, but I'm not sure how much help they can be. It *might* require a reinstall.

 

But in the meantime, put your system info in your profile page.

Share this post


Link to post
Share on other sites
I just uploaded A:M onto my new computer and for some reason my library doesn't seem to be coming up. All of the folders are in the computer, but not linked to the library.

 

First

Have you copied the *.lbr files from /Libraries also ?

 

Second

Are the location for this copied folder in the same place relative to the A:M main directory (on the mac normaly at /Applications/Animation Master 15.0/) ?

Share this post


Link to post
Share on other sites

I'm on a Mac OS 10.5.6 and I just discovered that my libraries are misbehaving badly.

 

A couple of months ago, after I'd installed the subscription version of v.15e, I noticed that my libraries were partially absent from the app folder, with only two or three models, three actions, one material, etc. Since I have the PC version at work I copied all the libs from there and installed them at home and everything showed up just fine. But the fact is I hardly ever use the libraries and don't usually have the panel open.

 

So in looking into Masna's problem I opened the lib panel, and my library content is mostly missing. the libraries are all present in the app folder, in a folder called Data. I tried to reset the link in the Options window but the links are messed up, and when I tried to reset them, upon relaunching they were still messed up and the lib content is not showing up as it should.

 

I think it may be connected to the 10.5.6 update that I mentioned in another thread a week or two ago. I think you're right, Masna. I may open an AM Reports file on this, as I can't seem to fix it so it stays fixed. As far as I can tell the libs were loading up just fine as recently as Sept.

 

If your lib content is present in the app folder you can of course always get it with Cmd-O, and just open a material, model, what have you.

 

EDIT: Inside the Data folder there's also a Libraries folder, which contains a 4kb Hash CD Library.lbr file. Should this be on the same level as the library content folders? Maybe that's the problem.

 

SECOND EDIT: I copied the .lbr file into a Libraries folder OUTSIDE the Data folder, and now my Libraries panel is completely blank. So I'm making progress! :blink:

Share this post


Link to post
Share on other sites
I may open an AM Reports file on this, as I can't seem to fix it so it stays fixed.

 

Please do this

and attach your MasterPrefs.ini and the lbr file.

I will look into this .

Share this post


Link to post
Share on other sites
Should this be on the same level as the library content folders?

 

Be careful in moving Libary files around manually.

This will automatically break the Shortcuts to the files in the Libraries.

 

Of course a fix in this case might be to move those assets to where the new location points to.

The more proper fix would be to fix the shortcuts. (this can be done in most text editors via 'search and replace')

 

To understand better how Libraries work open up a Library file in a text editor.

As Library files are text files you'll see where each entry points to.

If the resources are where the shortcuts point to and A:M see that Library. A:M will show the resources.

Share this post


Link to post
Share on other sites
Please do this

and attach your MasterPrefs.ini and the lbr file.

I will look into this .

Steffen, done! Thank you.

 

Gerry

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...