Jump to content
Hash, Inc. Forums

Archived

This topic is now archived and is closed to further replies.

mtpeak2

AMv13 2008 Rig Installer

Recommended Posts

Mark could what Animas done with the hands be done on any model allready rigged ?.Be good if you can but not a problem if not

Got a couple of charectors to put the latest rigg in anyway

Share this post


Link to post
Share on other sites

Mark I have an old model but don't kno what rig this is ,Iv been bettering the decals but don't understand the rig ,could you take a look please and see if you recognise it

Share this post


Link to post
Share on other sites

sent

The hand thing I was asking about is could I put it into my allready riged models

Share this post


Link to post
Share on other sites

The model has an old version of the squetch rig in it (not up-to-date).

 

The new finger controls are difficult to install into an already rigged model, that's what I'm working on for Michel.

Share this post


Link to post
Share on other sites

Thank's Mark ,no wander I didn't know it .Ok with the fingers Ill just use them in newer models ,but theye look real good

Share this post


Link to post
Share on other sites

Mark , would you know wich bones I need to put the waigts on I thought it was the geom bones but that don't seem to work I put some to the hip-geom but that don't work when I move the lower hip controller but doese when I move the hip null control

Share this post


Link to post
Share on other sites

Yes all geom bones. The hips_geom doesn't squetch, so it is used to blend the squetching between the stomach_geom and legs, if I remember correctly. David would know better than I would.

Share this post


Link to post
Share on other sites
Yes all geom bones. The hips_geom doesn't squetch, so it is used to blend the squetching between the stomach_geom and legs, if I remember correctly. David would know better than I would.

 

Yessir, it is for that and also to keep the origin of each leg from being affected by any squetching.

Share this post


Link to post
Share on other sites

Hell no I can't get that right ,So I deleated the bones and put the 2008 rig in BUT I got lots of hands and legs in the relationships folders, :( I forgot to take the relationships out .Is there any way to fix it or am I doomed.btw there is no IK on the hands and legs .Thought it was going to smooth

The only copy I have is before mirror bones is aplied

Share this post


Link to post
Share on other sites

Delete the relationship folder and the pose sliders from the user properties of your model. Then open the 2008 installer model and your model in the same project. Drag and drop the relationship folder from the installer model onto your models name in the PWS.

Share this post


Link to post
Share on other sites

Wow thank's a million Mark that worked like a charm,I thought it was a compleat redo thing .You saved me a lot of work there thank's again

 

edited

These finger controls work great Mark ,makes a lot of differance to what your able to do with the model

Share this post


Link to post
Share on other sites

Still got some work to do on it but that hand lock is dam good aswell

oa0.jpg

Share this post


Link to post
Share on other sites

Mark I want to smartskinn the fingers ,how would I do that using the new finger bones

Share this post


Link to post
Share on other sites

Turn ON the FK finger poses, those are the geometry bones.

 

Any FK mode ON/IK mode OFF/spine controls OFF, you are animating the geometry bones.

Share this post


Link to post
Share on other sites

Iv looked everywhere ,except where it is and can't find the face rig ,giz a pointer would you please

Share this post


Link to post
Share on other sites

The face rig is not part of the 2008 rig and I haven't posted an installer for it.

Share this post


Link to post
Share on other sites

Oh sorry I thought you had and I had miissed it for some reason

Share this post


Link to post
Share on other sites

I posted a new installer in my first post of this tread. It fixes a constraint target issue in the "Steady Left FK/IK Arm" pose.

Share this post


Link to post
Share on other sites

I screwed up big time on the update 8 fix for the left steady arm pose, I reposted it. So if you used the fix, you will need to redo it with a version of the model BEFORE the original fix. If you don't have a version before the fix, you can send me the model and I'll fix it for you.

 

The problem is that the pose fix wasn't set to it's default position in the user properties (0%). So if the pose was set to (-1), the arm may have moved from it's default position in the action and exported like that. This will cause your model to not be symetrical (geometry and bones) and will cause issues with mirroring pose.

 

This is a major problem and I'm sorry for any inconvience.

 

For the fix, import the update 8 fix model, turn OFF IK legs, IK arms and all spine poses in the user properties. Create new action and export model following the instructions.

Share this post


Link to post
Share on other sites

on page 72 of instructions it says right click mirror bones

mirror.jpg

this option does not come up for me.

mirror2.jpg

Share this post


Link to post
Share on other sites
on page 72 of instructions it says right click mirror bones

mirror.jpg

this option does not come up for me.

mirror2.jpg

 

Do you have the MirrorBones plugin installed, Gene?

Share this post


Link to post
Share on other sites
still a problem

 

Make a new model, put one bone in it and try running the plugin...does it show up? If it does, it may be a problem with the model. If it doesn't, then we'll have to do some other exploring. What version of A:M are you using? If you are using v15, are you using prior to v15f or later than v15f? There are specific versions of the plugin for before and after v15f. If that doesn't fix the problem, the only recommendation I have is to try re-installing A:M.

 

Hope that helps, Gene.

Share this post


Link to post
Share on other sites

ok all the mirror hxt files are giving me failed to load errors on boot up of A:M

Share this post


Link to post
Share on other sites

I think I got it

fix.jpg.

not sure whats up with the yellow bone on the left.

Share this post


Link to post
Share on other sites

he is rigged but right side has no controls nor acts like left.

what did I do wrong?

left side is almost perfect.

superscreen.jpg

 

 

 

I like alot of things about this rig.

Share this post


Link to post
Share on other sites

The first thing I notice is that your model is not symetrical (model is quite a bit off center). The plugin did not mirror the fanbones, do to the fact that the model is not centered (copied, flipped and attached). I'm betting the the left side bones did not parent correctly either, for the same reason (that's why the fanbones didn't mirror).

 

Your best bet (if you still have a version saved before running the plugin), is to delete the left side of your model (right side of the screen), and copy, flip attach (making sure the center spline is at 0 on the X axis). You don't have to worry about the belt or any hair geometry being mirrored.

 

If you're still having problems you can post the model or e-mail it to me and I'll see what the problem is.

Share this post


Link to post
Share on other sites

ok it is things like this that make me wanna just stop and never try again.

after 2 days rigging I have this........

grrr2.jpg

put him in a choreography and I have 2 seperate rigs??????????????????

grrr1.jpg

I know it is something I am doing wrong but I have little patience with things.

2 days....sigh

actionman.mdl

Share this post


Link to post
Share on other sites
ok it is things like this that make me wanna just stop and never try again.

after 2 days rigging I have this........

grrr2.jpg

put him in a choreography and I have 2 seperate rigs??????????????????

grrr1.jpg

I know it is something I am doing wrong but I have little patience with things.

2 days....sigh

actionman.mdl

 

I did a quick look and saw that some bones are created that shouldn't be there, Gene. It looks like the rig wasn't centered when you mirrored the bones...and the character wasn't centered when modeling. That would be why there is a "leftBody" bone and it's children...which shouldn't be there.

 

Hope that helps.

Share this post


Link to post
Share on other sites
I had it set at 0

I dont know what else I can do.

 

Here is the model with the rig corrected...at least the duplicated bones. You'll have to do the left side weighting...but you won't be able to accurately mirror the weights since the model is not centered, so you'll have to manually weight it.

 

Hope that helps, Gene.

actionman_update.mdl

Share this post


Link to post
Share on other sites

Here is a fixed model. I recopied, flipped and attached the head, snapped to mirrored point on the body and set the center spines to 0 on the X axis. I also deleted all the bones the plugin created on the previous attempt. This model MirrorBones correctly, but I strongly suggest spending more time weighting before running the plugin.You may need to fix some groups.

 

Also, I see the Left side bone had a lower case "L". Make sure you settings in the MirrorBones plugin are EXACTLY the same as the settings in the instructions.

actionman_Mark.mdl

Share this post


Link to post
Share on other sites

Thanks

So my problem is.....everything MUST be on "0"

Thanks for the fix, although this is something I need to master myself.

I want to be able to rig on my own.

I have no idea whatsover what weighting is.

 

Thanks,

Gene

Share this post


Link to post
Share on other sites

An updated installer (removed duplicate constraints) and installation notes have been added.

Share this post


Link to post
Share on other sites

Hey Mark, I've just reviewed this whole thread to try to get up to speed with the 2008 rig. I wondered if the face rig is pretty much gone or if you have reconsidered getting back to it.

Share this post


Link to post
Share on other sites

I haven't done much in updating the face rig and setting up an installer (a few things I need to update and add). I wanted to take a look at A:M Track2's new rigging setup. My face rig is base on Luuk's original setup. I use it in the models I rerig, but that's about it.

 

It's not that difficult to install (pretty easy), but the weighting takes alot of time. I really haven't had any motivation in writing up any instructions for it either, that's the biggest obstacle. There wasn't a whole lot of feedback from the example model I posted, so things came to a hault fairly quickly.

 

As I said, it still needs some work, but I haven't really gotten the urge to work on it. One of these days. I have a new updated spine for the 2008 rig (5 bone spine, works like TSM2 rig), but there are other things I want to eventually update as well.

Share this post


Link to post
Share on other sites

×