Jump to content
Hash, Inc. Forums

Archived

This topic is now archived and is closed to further replies.

mtpeak2

AMv13 2008 Rig Installer

Recommended Posts

Well, here it is, finally. Sorry about the large file size. I had 2 versions of the instructions, but I settled for just the PDF, the other added another 7megs to the zip file.

 

I hope I was thorough enough and clear enough with the instructions, I'm sure you'll let me know if I wasn't. ;) It's not the best of instructions, but should do the job. As I've said before, I'm not very good at this sort of thing.

 

So, if you have any problems with the installation process, let me know.

 

 

Here the link to the MirrorBones plugin. http://www.sgross.com/plugins/

 

[EDIT] Updated relationships and added installation notes. To fix a model that has the previous version of the rig (update 9), just drag and drop the relationship folder from the installer to your models name in the PWS. You will need to reexport your model from an action, following the instructions.

Windows_InstallRig.zip

OSX_InstallRig.hxt.zip

Example_Models.zip

v13_2008_Rig_Installer_4_20_2011.zip

Share this post


Link to post
Share on other sites

Face rig installer coming soon, just not sure how soon though. I need a break.

 

Here's a link to an example face rig I'm working on.

Share this post


Link to post
Share on other sites

Thank's Mark this looks good to follow ,you can take a break now ,go get a coffee or a beer ,but get back soon lol

Share this post


Link to post
Share on other sites

Those instructions look very comprehensive and easy to follow. Got to wait until I get home to try out. Thanks Mark. There was obviously a lot of work involved in this...I can see that!

Share this post


Link to post
Share on other sites

This is strange I don't get a install rig when I go to the wizard, I dl'd the mirror bones plugin and put it in the hxt folder in v15 ,do I need something ells ?

Share this post


Link to post
Share on other sites

Thank you Mark!

I read your installations instructions, very well done.

 

Michel

Share this post


Link to post
Share on other sites

Read through the instructions.. it all makes sense to me.

 

I have question. How would this rig be a benefit over say... any other rig like TSM or whatever? This is the "official" 2008 Rig? I would like to rig my Terminator model. I am bit... afraid of using TSM for that since it isn't really being supported any longer. I've always liked the 2001 rig in the past. Hope this is okay to post this question here.

 

-vern

Share this post


Link to post
Share on other sites

This is awesome. I hope to be using this rig soon and often. Thank you, Mark, for all of your time & hard work.

Myron

Share this post


Link to post
Share on other sites

Thank's Mark ,these instructions are easy to follow ,even for me

Share this post


Link to post
Share on other sites

Thanks everybody.

 

Vern, benefit over TSM2 rig (FK/IK switching) Squetch rig (no recompensation of constraints) 2001 rig (alot). I'm not sure what you mean by "official" 2008 rig.

Share this post


Link to post
Share on other sites

Even though I was incredibly tired last night I couldn't wait to get started on testing this out so had about 30 minutes or so on it. I haven't finished yet but so far the instructions are very easy to follow and I'm looking forward to completing tonight. Thanks Mark.

Share this post


Link to post
Share on other sites

I step away from the computer for a day and look what shows up while I'm out!

I guess I know what I'll be doing this weekend. :)

 

Thanks Mark!

Share this post


Link to post
Share on other sites
I'm not sure what you mean by "official" 2008 rig.

 

Sanctioned by Hash, like the 2001 rig was... I guess it was. All the models and actions on the CD used the same rig. It was like an "official" rig. Is this 2008 rig the one used in the movie (TWO, SO) projects? Or was the squetch rig? Rather than go off on some other tangent I would like to use what the hoi polloi use. ;) I never had much luck with "less popular" or unsupported rigs. TSM is great but... yikes... it's no longer being developed.... it may just die at some future version. Good grief it's 2008 and the 2001 rig was the standard for a long long time.

 

-vern

Share this post


Link to post
Share on other sites

Vern, I don't know if it's going to replace the 2001 rig on the CD. The squetch rig was use in TWO and SO.

Share this post


Link to post
Share on other sites

I found 2 corrupt constraints in the IK leg setup. I posted a new installer in my first post.

 

If you are in the middle of an install, drag the relationship folder from the new installer to your model. If you already exported your model from an action, drag the relationship folder to your model and reexport your model from an action. Make sure the IK leg setups are turned off, in the models user properties, before exporting.

 

There also may be an issue with the MirrorBones plugin in v15. I'll look into that as soon as I can.

 

Sorry for the inconvience.

Share this post


Link to post
Share on other sites

Hi Mark,

 

Thank you for that great rig.

I am starting my own thread, where I try to rig my Simplerigman with 2008 rig following your instructions.

 

 

;>) Jake

Share this post


Link to post
Share on other sites

I posted another update in my first post.

 

I found a couple of oversights by me. First is I didn't name the carpal bones with Geom in the name, they get hidden after running the InstallRig plugin. Second is in the instructions, a few people have had scaling issues during the install. They didn't scale the bones in the X, Y and Z axis' equally, which causes problems. So, I update the instructions to reflect that as a reminder in each scaling situation.

 

I still need to look at the MirorBones plugin issue in v15. I've also noticed v15 is not CFAing the same as v13 or v14, there is some kind of offset/tolerence issue, which is causing the MirrorBones plugin to not assign cps properly. I'll try to look into this on the weekend, I have alot of other things to take care of as well, so my time is limited.

 

Sorry for inconvience.

Share this post


Link to post
Share on other sites

It's no inconvenience. It will be good practice for me to do it over again. Atleast I know I'm not as stupid as I thought I was!

I'm just grateful to you for creating this and for always helping out with problems. Whenever you get time is fine - you don't have to do it at all! :)

Share this post


Link to post
Share on other sites
If you are in the middle of an install, drag the relationship folder from the new installer to your model...

 

I am in the process of cp weighting (page 71), so I guess that means I'm in the middle of an install. I'm not sure what you mean by "drag the relationship folder from the new installer to your model". How would I do that exactly? How would I gain access to the new relationship folder? Do I import the new installer into an older version of the model, and then "drag" the new folder over?

 

Thanks.

Share this post


Link to post
Share on other sites

First thing I want you to do is unhide and rename a few bones. (see image)

rename.jpg

Share this post


Link to post
Share on other sites
If you can't seem to do this, you can send me the model and I'll fix it.

 

It worked perfectly as far as I can tell. As soon as I dropped the new Relationships folder onto my character, it appeared to replace the old folder with no questions asked. I did see an asterisk next to the folder afterwords.

 

I was wondering where those hand bones went... ;)

 

Thanks for your help!!

Share this post


Link to post
Share on other sites

I found a major problem with the latest MirrorBones plugin, I doesn't mirror nulls correctly, it only mirrored some of the nulls, not all of them.

 

Steffen, Can you take a look at that?

 

[EDIT] I did a test with the MirrorBones plugin and everything worked ok. I'm not sure what the problem was, it may be the model I'm rigging. So the plugin seems ok.

 

There are some thing I want to update on the installer, some of the control bones need scaling during the installation, I'm hoping I can take care of that when the model gets exported. I'll try to get an update posted as soon as I can.

Share this post


Link to post
Share on other sites
[EDIT] I did a test with the MirrorBones plugin and everything worked ok. I'm not sure what the problem was, it may be the model I'm rigging. So the plugin seems ok.

 

I was about to start a new topic about that, but then I saw your edit.

 

I did have a problem with the MirrorBones plugin on an earlier version of the model, but I realized that the CP's were probably not 100% the same on both sides (I did some fine tuning and forgot to turn on Mirror Mode). So I literally deleted the left side entirely and worked on it until I got a perfect CFA. Then I started over with the 2008 Rig instructions; including CP weighting... which I found just as challenging as modeling... :huh:. This time around, the Mirror Bones procedure appears to have worked perfectly (although the Balance Left Foot was turned off).

 

Looking forward to the face rig installer.

 

Thanks

Share this post


Link to post
Share on other sites

The Balance Right Foot null should be hidden after positioning the setup (instructions say to Shift+J the Balance INSTALL bone when finished) this hides that null and the rest of the setup that is visible. The InstallRig plugin does not work on nulls to hide them, that's why I said to Shift+J the Balance INSTALL, which hides the children of that bone as well. So, the Balance Left Foot null should be hidden anyway.

 

The face rig is on the back burner for now, til I get the 2008 rig straighten out. I have another update I will be posting shortly. Plus I have other things I'm working on at the moment, which will help me get the face installer ready at some point.

Share this post


Link to post
Share on other sites

Posted a new update to the installer in my first post, which fixes the scaling of the spine and foot controllers when exporting the model from an action. This is not a big issue, just something I wanted to take care of.

Share this post


Link to post
Share on other sites

Hi Mark

 

I am finally feeling better and have started back playing with AM. I have followed the rig but had a question. (I have 15e running) Is the mirror bones plugin working on 15?

 

Thanks, I am getting started tonight.

 

Steve

Share this post


Link to post
Share on other sites

The problem is the plugin is processing too much at once, I think. Possible work around, after positioning the rig, run the install rig and mirrorbones plugin, before assigning and weighting cps. After assigning and weighting cps on the right side, run the mirrorbones plugin again. I haven't tested this, but I will soon. I think this will work. I have no problems with the mirrorbones plugin with just the rig, it seems to only happen after cps are assigned and weighted. I haven't had time to look into this yet.

Share this post


Link to post
Share on other sites

I started trying to rig Lambrina from the Extras DVD. Quick question ... she is wearing high-heeled shoes. Should I make the Right Leg INSTALL go to her ankle, and move the Right Foot_Geom bone to match up with it? Should the foot bone be straight up-and-down, or on an angle?

 

My best guess is to keep the Right Foot_Geom straight up-and-down at the base of Right Leg INSTALL and continue to position Right Toes_Geom and Right Ball Orient Target and Right Heel Orient Target as described in the tutorial. The other option would be to pretend the high heels don't exist and pretend the ankle joint is lower than it is, but I'm guessing that would cause problems with control points and trying to rotate the foot.

Share this post


Link to post
Share on other sites

Updated my first post with an update to the installer and instructions (found missing constraints and fixed the typos in the instructions). Also posted a zip containing Thom and Robby with the fix.

 

Thanks Chris for finding the typos.

Share this post


Link to post
Share on other sites

Just finished the second model with the 2008 rig one thing I just can't remember ,how to show the bones for smartkinning .It worked graet Mark ,thank's for sorting that mirror bones thing out

Share this post


Link to post
Share on other sites

Turn OFF the IK legs and arms and all the spine poses. Also turn ON the FK fingers.

Share this post


Link to post
Share on other sites

I found an issue with the last installer, update4. I posted a new installer in my first post of this thread.

 

To fix the issue, if you used the update4 installer........

 

Delete the Relationship folder from your model and drag and drop the Relationship folder from the new installer to your models name in the PWS.

 

Or........

 

If you created your own poses and do not want to delete the whole Relationship folder, rename these bones IN THE POSE FOLDER, with "_Geom" on the end of the names, no quotations. The bones to ADD "_Geom" to are located in the Rig Relationships>Basic Setup Relationships. I posted an image showing the bones to rename.

 

Sorry for the inconvience.

Carpal_Fix.jpg

Share this post


Link to post
Share on other sites

Found a few parent bones in the spine being out of position after exporting the model from an action. Posted a new updated installer in my first post.

 

To fix a model that was rigged with the last update, open your model and the new installer into the same project. Open the relationship folder of the new installer. Go into the spine folder and open the "Header Controller, Chest Controller and the Pelvis Controller" poses til you see relationship 1. Drag each relationship onto your models name in the PWS. Now turn OFF the IK Arms, IK Legs and all the spine poses in your models User Properties. Create a new action with your model and export your model from the action. Start a new project and open your exported model and turn the IK poses and the spine poses back ON in your models User Properties and save your model.

 

Sorry for the inconvience.

 

This update does not include the new finger controls. I'm not sure if I'm going to add them or not. Since Steve is the only one that gave me any feedback on the controls, I don't think it's worth the effort to implement them into the installer. Sorry Steve.

Share this post


Link to post
Share on other sites

Thats sad news Mark ,but I do understand .Thank's for puting the fix up instead of just the new dl ,that helps a lot .Are you still considering the face controls ?

There must be others using this rigg its so dam good and not that difficult to put into a model

Share this post


Link to post
Share on other sites

As for the face rig installer, probably not. There's only a handful of people DL'ing the 2008 rig, which isn't even worth the effort to update anymore, if there is problems.

Share this post


Link to post
Share on other sites
:(:blink: I can't believe so few are using it ,its the esiest Iv found to work with and it doese more ,theres no fatheming it

Share this post


Link to post
Share on other sites

Mark,

 

The fact that only so few people are using it at the momement for sure doesn`t mean, there is no interest in it!

 

As far as I am concerned , I have been following your posts with greatest interest and your solutions

seems for me to be the best solutions and I plan to use them as soon as I find the time to get out of

job-and family obligations again to get back to work with AM.

 

There must be many people like me silently watching, who cant work with AM professionally all the time

but still follow your work and highly appreciate it.

As far as I have looked into it, I think your rig is very,very versatile and pretty easy to install at the same time.

 

I would appreciate it very much, if you would continue it`s maintainance,(if even at a slower pace)

(also the fingercontrols and the facerig)

 

I think succsess will be with you in the longer run!..

 

Anyway , thanks a lot again for your FREE work so far on your awesome 2008-rigg!

 

;>) Jake

Share this post


Link to post
Share on other sites

×