Jump to content
Hash, Inc. Forums
Sign in to follow this  
Tralfaz

Duplicate Bone Structure

Recommended Posts

Hey folks. I am working on rigging my AT-AT and have a question (well actually two).

 

I have rigged one of the legs right down to the toes. I am hoping that I won't have to do each of the other three legs manually. Is there a way to take the entire leg bone structure and duplicate it for the other three legs? I know I will have to move the structure to the other three legs and assign the control points, but was hoping there was an easy way of doing things.

 

Also, is it possible to define and set up the constraints in the model window or do they have to be created in an action window?

 

Thanks in advance...

Al

Share this post


Link to post
Share on other sites

Well, here's an idea.....

 

Make a copy of your model.

Delete everything but the bones you want to duplicate.

Save and open that model in notepad and see if you can copy the information and paste it into another copy of your intact model (also opened in notepad).

You might need to rename the bones in notepad.

 

If it works, just paste it three times.

Share this post


Link to post
Share on other sites
Hey folks. I am working on rigging my AT-AT and have a question (well actually two).

 

I have rigged one of the legs right down to the toes. I am hoping that I won't have to do each of the other three legs manually. Is there a way to take the entire leg bone structure and duplicate it for the other three legs?

 

If you hold down the CTRL key whil you drag the root of your structure up to the Bones folder it will duplicate the tree. They get numerals appended to them to prevent name duplication, whish may or may not aid in renaming.

 

If you do Ken's Idea you could take the new 1 leg model into a text editor and do a search and replace to change the whole tree from "front left..." to "rear left..." or "front right" or "rear right", then taek it back to your original model.

 

edit: oh , i see ken mentioned notepad.

 

Also, is it possible to define and set up the constraints in the model window or do they have to be created in an action window?

normally you'd do your constraints in a "pose" so they will live in the same file as your model.

Share this post


Link to post
Share on other sites

Name the bones all right or left, depending on the side. Create a parent bone for the leg bone structure (if you don't have one already) at 0,0,0 in the PWS. Drag the new parent bone to it's parent while holding the control key, this creates a duplicate with all children. Translate the duplicate parent using the manipulator to position it to the front or back leg. Now position them accordingly and assign the cps to that half of the model. Then you can use the MirrorBones plugin to duplicate the other side, with cps assigned automaticly.

Share this post


Link to post
Share on other sites

Thanks to everyone for your suggestions.

 

Doing the 'CTRL' while dragging the root bone structure worked like a charm. I had already been naming the bones 'Right Rear this' and 'Right Rear that'. Easy enough to rename them to 'Left Rear this' and "Left Right that' as well as remove the number 2 from the end of the names.

 

I created an ON/OFF Pose for setting up all the constraints on the bones, and this is working like a charm.

 

One more question though. On the Percentage poses, I am able to go into the settings and set the default value for the pose (e.g. 50) so that when the model is used in an action or a chor, the pose will start off with a default value of 50.

 

I wasn't able to find a way to set the default value for an ON/OFF pose to ON. I am sure there must be a way to do this, but have not been able to find it in the manual or on-line here. Anyone have any ideas?

 

Thanks...

Al

Share this post


Link to post
Share on other sites
I wasn't able to find a way to set the default value for an ON/OFF pose to ON. I am sure there must be a way to do this, but have not been able to find it in the manual or on-line here. Anyone have any ideas?

 

In the model's "User Properties" your pose will probably appear as "not set". Set it to ON and resave the model.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...