Jump to content
Hash, Inc. Forums
Sign in to follow this  
Overcast

Properties reverting, what the heck!?

Recommended Posts

Hey y'all!

SO I'm working on an extremely simple character rig, and i followed a tutorial for how to do shoulders without using smartskin (which works great, by the way). And I'm thinking that set-up is irrelevant, because this happens with a lot of my constraints-

I open a smartskin simply so that I can apply a constraint to a bone (If theres another way to apply a constraint to a bone, PLEASE tell me!!)

I constrain a non-related bone to another non-related bone to execute an 'orient like' constraint. Simple enough. I then set the enforcement to 50%, or 15% or whatever percent i FREAKIN feel like.

All is well and dandy, it works fantastically in an action, chor, whatever. I repeat the process with several bones.

 

-then-

 

I Save.

I Quit.

I Sleep.

I Wake up.

I Decide to work on my character again.

 

-but-

 

NO! All of the constraints that were applied have reverted to 100%, are unchangable, and DONT HAVE AN EFFECT in an action or chor!

Can anyone explain why this is? In order to get them to work, I have to delete them, and redo all of them. This, at this point, involves 12 bones, and in the future will probably involve about 30. Helps? (Sorry I cant find the tutorial, but if anyone knows, it's the shoulder tut where a group of 'shoulder ring' bones are constrained to a bicep bone...)

Thanks,

L

Share this post


Link to post
Share on other sites
I open a smartskin simply so that I can apply a constraint to a bone (If theres another way to apply a constraint to a bone, PLEASE tell me!!)

 

Maybe you have your terms confused...or maybe that is what you're doing. To apply constraints in your rig, you should be making "Poses". Right mouse-click on the name of your model in the PWS (Project Workspace), select "New", under that you will find "Pose" and under that you will find "on/off" and "percentage"...select either an on/off pose or percentage pose depending on what you need. Inside that pose, make your constraints then close the pose. Select your model in the PWS, look in the "Properties" menu and select "User Properties", your pose will be in there...turn on the pose there if you want the pose to be on all of the time.

 

All of the constraints that were applied have reverted to 100%, are unchangable, and DONT HAVE AN EFFECT in an action or chor!

 

If you haven't opened a pose, the percentages will appear to be 100%, open the pose and they will be displayed as they were set. Also, your pose probably isn't turned on since it isn't affecting anything.

 

Here is a tutorial that has a quick overview of constraints at the beginning. Hope that helps, Layton.

Share this post


Link to post
Share on other sites

Its hard to comment well without knowing what version you are using. You should include this. Beyond that, ItsJustMe is right -- use an off/on pose to apply permanent constraints to a model -- I suppose smartskin should do it as well but I've never tried it.

 

Rusty

Share this post


Link to post
Share on other sites

Hahahahahahaha

You're totally right.

No seriously, I was using smart skins... wow what a stupid mistake!

Thanks a lot.

L

Share this post


Link to post
Share on other sites

Yeah... I was doing the same thing until I saw itsjustme's mondo quicktime tutorial which told me more about AM rigging in the first 30 seconds than I had known in the entire course of my corporeal existence.

 

Thanks Itsjustme :D

Share this post


Link to post
Share on other sites

Yes, this is another frustrating glitch that I have found in A:M 12.0v+. I have reported it to 'A:M Reports' and you should all do the same.

 

What seems to be hapening is that when you set a constraint's percentage A:M will find the previous constraint that you set, not the one you are currently setting, and modify it. (I think A:M was setting all of mine to 0%). To work around this you will need to backtrack every time you set a percentage and reset the values that A:M has changed. It is frustrating and doubles the time it takes to setup your constraints but hopefully it will be fixed in the next update.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...